axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yuanfeng Zhang <yuanfeng.zh...@gmail.com>
Subject Error With tcp transport
Date Fri, 08 May 2009 12:07:48 GMT
HI,

   I run axis2_tcp_server as a tcp server, but it seems not work. The logs
are list below:

=========================================================================================
[Fri May  8 19:59:29 2009] [info]  Starting TCP server thread
[Fri May  8 19:59:49 2009] [debug] tcp_svr_thread.c(255) tcp request <?xml
version='1.0' encoding='utf-8'?><soapenv:Envelope xmlns:soapenv="
http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><operation
name="user_authorization" version="version01" src="web"><request_head
user_name="756" password="password" req_sequence="1241783779414"
passport="passport"><host_id>2147483647</host_id></request_head><user_authorization
user_id="756" passport="d87ac94u5a"
/></operation></soapenv:Body></soapenv:Envelope>
[Fri May  8 19:59:49 2009] [error] soap_builder.c(921)
AXIS2_ERROR_TRANSPORT_LEVEL_INFORMATION_DOES_NOT_MATCH_WITH_SOAP
[Fri May  8 19:59:49 2009] [error] tcp_worker.c(127) Failed to create SOAP
builder
[Fri May  8 19:59:49 2009] [warning] tcp_svr_thread.c(285) Error occured in
processing request (0.001 seconds)
=========================================================================================

the server received a request, but it didn.t think it as a correct soap
message, why?  Please help me with it!

the client side is axis2(java version) ServiceClient.

Mime
View raw message