axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raymond Zhou <raywang...@yahoo.com>
Subject downloaded axis2/c 1.4 cannot load rampart/c module when start axis2_http_serve
Date Thu, 12 Mar 2009 00:19:50 GMT
Hi All,
 
I downloaded axis2/c 1.4 binary build and rampart/c 1.2 binary build, and I followed steps
to do the configurations, I am having trouble starting axis2_http_server.exe when I engaged
rampart/c. If I don't engage rampart/c, I have no problem at all, I can start the http server,
and ran the client examples. But when I engaged the rampart/c, I got the following error and
axis2_http_server.exe won't start:
 
==========
[Wed Mar 11 17:02:14 2009] [debug] ..\..\src\core\deployment\dep_engine.c(1306) axis2_dep_engine_load_module_dll:
DLL path is : ..//modules/rampart/mod_rampart.dll
[Wed Mar 11 17:02:14 2009] [error] ..\..\util\src\class_loader.c(161) dlerror reason: Something
went wrong loading the DLL. If you happen to see this message, please note that getting the
exact error form Windows is a TODO. And if possible please help fix it. :)
[Wed Mar 11 17:02:14 2009] [error] ..\..\src\core\deployment\dep_engine.c(1424) Loading module
description rampart failed
[Wed Mar 11 17:02:14 2009] [error] ..\..\src\core\deployment\dep_engine.c(1588) Adding new
module rampart to the deployment engine failed
[Wed Mar 11 17:02:14 2009] [error] ..\..\src\core\deployment\repos_listener..c(136) Repository
listener initialization failed
[Wed Mar 11 17:02:14 2009] [error] ..\..\src\core\deployment\dep_engine.c(788) dep_engine
repos listener creation failed, folder name is ../
[Wed Mar 11 17:02:14 2009] [error] ..\..\src\core\deployment\conf_init.c(64) Loading deployment
engine failed for repository ../.
[Wed Mar 11 17:02:14 2009] [error] ..\..\src\core\transport\http\receiver\http_receiver.c(127)
unable to create private configuration contextfor repo path ../
[Wed Mar 11 17:02:14 2009] [error] ..\..\src\core\transport\http\server\simple_axis2_server\http_server_main.c(215)
Server creation failed: Error code: 34 :: Repository listener initialization failed
==========
 
To engage rampart/c, I did the following:
(1) Added <module ref="rampart"/> to axis2.xml
(2) add follwoing phase under <phaseOrder type="outflow">    <phaseOrder type="outflow">
        <!-- Other Phases-->
        <phase name="Security"/>
   </phaseOrder

(3) Copied rampart/c 1.2 module to axis2/c modules.
(4) Copied samples\server\sec_echo to %AXIS2C_HOME%\services 
 
Has anyone been successful using rampart/c? I am trying to use rampart/c in a web service
client componet which I am successfully using axis2/c 1.5.
 
Thanks much in advance!
Ray


      
Mime
View raw message