axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From balajikumara T <balajikum...@gmail.com>
Subject Re: server sends output but client unable to deserialize
Date Tue, 17 Feb 2009 17:22:07 GMT
Hi
sending the code walk thru which i debugged

Thanks
Balaji


On Tue, Feb 17, 2009 at 12:00 PM, balajikumara T <balajikumara@gmail.com>wrote:

> Hi
> Attaching it
> Thanks in advance
> Balaji
>
>
>
> On Tue, Feb 17, 2009 at 11:43 AM, Supun Kamburugamuva <supun06@gmail.com>wrote:
>
>> Can you please attach the log file?
>>
>> Supun
>>
>>
>> On Tue, Feb 17, 2009 at 9:26 PM, balajikumara T <balajikumara@gmail.com>wrote:
>>
>>> Hi,
>>> I get the following error.
>>> Mon Feb 16 10:54:10 2009] [error] adb_testScorecard.c(750) non nillable
>>> or minOuccrs != 0 element PVOutput missing
>>> [Mon Feb 16 10:54:10 2009] [error]adb_testResponse.c(203) failed in
>>> building adb object for element testReturn
>>> [Mon Feb 16 10:54:10 2009] [error]adb_test.c(213) failed in setting the
>>> value for testReturn
>>> [Mon Feb 16 10:54:10 2009] [error] axis2_stub_test_v1Service.c(1549)
>>> NULL returnted from the test_deserialize: This should be due to an invalid
>>> XML
>>>
>>> The problem is ,I get the output for n number of time (say 3-5) and after
>>> that i get response  from server in the return output.( i see it in tcpmon)
>>> ,but when deserializing happens at client side, it just not able to
>>> deserialise all output. In all cases it is the same request that is sent.
>>>
>>> If i stop the client and then restart and if i send the same request ,it
>>> works and after sometime it will not work.
>>>
>>> Why is this happening? Is this is a problem with some memory leak,buffer
>>> overflow. I saw some post on this where it was  mentioned about commenting
>>> the free call
>>>
>>>  if(_testResponse)
>>>             {
>>> #######                AXIS2_FREE(env->allocator, _testResponse);
>>>                 _testResponse = NULL;
>>>             }
>>> I tried that as well, but it doesnt work.
>>>
>>> Can anyone throw some light on this
>>>
>>> Thanks in Advance
>>> Balaji
>>>
>>>
>>>
>>
>>
>> --
>> Software Engineer, WSO2 Inc
>> http://wso2.org
>> supunk.blogspot.com
>>
>>
>>
>

Mime
View raw message