axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S Balaji <ija...@yahoo.com>
Subject Re: error while loading axis2/c module "The specified module could not be found"
Date Mon, 23 Feb 2009 12:41:39 GMT


Sorry perhaps I am confusing Axis2/C with Axis C++. My apologies. 


--- On Mon, 2/23/09, S Balaji <ijalab@yahoo.com> wrote:

> From: S Balaji <ijalab@yahoo.com>
> Subject: Re: error while loading axis2/c module "The specified module could  not be found"
> To: "Apache AXIS C User List" <axis-c-user@ws.apache.org>
> Date: Monday, February 23, 2009, 7:31 AM
> Hi Sasank, 
> 
> I had same problem with Apache 2.2 server and axis
> axis-c-1.6b-Win32-trace-bin on my windows 2000 Advanced
> server laptop. Here are some things I can think of : 
> 
> *) Take latest Axis cpp source and build it ? I am yet to
> locate this. I was told axis-c-1.6b-Win32-trace-bin is
> pretty old. You said you are running even older version :
> 1.5
> *) Make sure apache web server is built with module .so
> support. 
> *) When I got this problem myself, I googled a bit and
> found a small piece of code which can help you isolate what
> problem you are having with your specific mod_axis2.dll : If
> you need the executable, I can send you that as well.
> #include <windows.h>
> int main( int argc, char** argv )
> {
>    char szLibrary[] = "mod_axis2.dll";
>    HANDLE os_handle = LoadLibraryEx( szLibrary, NULL, 0 );
>    return 0;
> }
> 
> 
> *) Ultimately I could not get it to work but I did not
> bother, as I dont particularly need my web services server
> side to run in C++. I am only interested in c++ client. 
> 
> Sorry if this is not much help. 
> 
> 
> 
> 
> --- On Mon, 2/23/09, sasanka pusapati
> <spusapatinlr@gmail.com> wrote:
> 
> > From: sasanka pusapati <spusapatinlr@gmail.com>
> > Subject: Re: error while loading axis2/c module
> "The specified module could  not be found"
> > To: "Apache AXIS C User List"
> <axis-c-user@ws.apache.org>
> > Date: Monday, February 23, 2009, 6:52 AM
> > Hi ,
> > 
> > The original text that i have added in httpd.conf
> after
> > copying mod_axis2.so
> > into modules directory was
> > 
> > LoadModule axis2_module modules/mod_axis2.so
> >     Axis2RepoPath
> > "c:/axis2c-bin-1.5.0-win32/axis2c"
> >     Axis2LogFile
> > "c:/axis2c-bin-1.5.0-win32/axis2c/axis2.log"
> >     Axis2ServiceURLPrefix /service
> >     Axis2LogLevel debug
> >     Axis2MaxLogFileSize 100
> >    <Location /axis2>
> >        SetHandler axis2_module
> >    </Location>
> > 
> > but this is throwing following error
> > 
> > "httpd.exe: Syntax error on line 127 of
> C:/Program
> > Files/Apache Software
> > Foundation/Apache2.2/conf/httpd.conf: Cannot load
> > C:/Program Files/Apache
> > Software Foundation/Apache2.2/modules/mod_axis2.so
> into
> > server: The
> > specified module could not be found.  " , but the
> file
> > mod_axis2.so do exist
> > in modules directory.
> > 
> > 
> > 
> > Is there any thing else i need to configure ...
> > 
> > Thanks in Advance,
> > Sasanka.
> > 
> > On Mon, Feb 23, 2009 at 5:01 PM, Supun Kamburugamuva
> > <supun06@gmail.com>wrote:
> > 
> > > These are not matching
> > 
> > 
> > 
> > 
> > >
> > >
> > >   <Location /axis2>
> > >        SetHandler axis2_module
> > >    </Location>
> > >
> > > and
> > >
> > > LoadModule axis_2module modules/mod_axis2.so
> > >
> > > Supun..
> > >
> > >
> > > On Mon, Feb 23, 2009 at 3:26 PM, sasanka pusapati
> > <spusapatinlr@gmail.com>wrote:
> > >
> > >>
> > >>
> > >>
> > >>
> > >> Hi Axis2/c Users,
> > >>                             I am new to
> Axis2/c. I
> > am trying to configure
> > >> apache 2.2.9 with axis2/c module but i am
> unable
> > to load the axis2/c module.
> > >> I downloaded the binary of axis 1.5 and
> copied the
> > mod_axis2.dll as
> > >> mod_axis2.so into modules directory. I also
> > modified the httpd.conf
> > >> When i restart the Apache web server i am
> getting
> > the following error
> > >>
> > >> "httpd.exe: Syntax error on line 127 of
> > C:/Program Files/Apache Software
> > >> Foundation/Apache2.2/conf/httpd.conf: Cannot
> load
> > C:/Program Files/Apache
> > >> Software
> Foundation/Apache2.2/modules/mod_axis2.so
> > into server: The
> > >> specified module could not be found.  "
> , but
> > the file mod_axis2.so do exist
> > >> in modules directory.
> > >>
> > >> Following is the text added in httpd.conf:
> > >>
> > >> LoadModule axis_2module modules/mod_axis2.so
> > >>     Axis2RepoPath
> > "c:/axis2c-bin-1.5.0-win32/axis2c"
> > >>     Axis2LogFile
> > "c:/axis2c-bin-1.5.0-win32/axis2c/axis2.log"
> > >>     Axis2ServiceURLPrefix /service
> > >>     Axis2LogLevel debug
> > >>     Axis2MaxLogFileSize 100
> > >>    <Location /axis2>
> > >>        SetHandler axis2_module
> > >>    </Location>
> > >>
> > >> Smart brains.. can you please help me in
> resolving
> > this issue....
> > >>
> > >> Thanks in Advance,
> > >> Sasank.
> > >>
> > >>
> > >>
> > >> --
> > >> sasanka Pusapati
> > >>
> > >
> > >
> > >
> > > --
> > > Software Engineer, WSO2 Inc
> > > http://wso2.org
> > > supunk.blogspot.com
> > >
> > >
> > >
> > 
> > 
> > -- 
> > sasanka Pusapati


      

Mime
View raw message