axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Uthaiyashankar <shan...@wso2.com>
Subject Re: rampart/c compilation error related to openSSL
Date Tue, 24 Feb 2009 03:53:13 GMT
Hi,

It is a known problem in openssl (NOT in Rampart/C :D ) . Have a look at [1]
to solve it.

Regards,
Shankar

[1] http://wso2.org/forum/thread/3861


On Tue, Feb 24, 2009 at 6:37 AM, Raymond Zhou <raywang999@yahoo.com> wrote:

> Hi All,
>
> I am using open source axis2/c and rampart/c to build a secure web service
> client.  I am now getting some openSSL related compilation errors in windows
> XP, here are the details:
>
> (1) If I downloaded the binary version of openSSL, I can compile axis2/c
> and rampart/c without any problem, and the functionalities seem work fine.
>
> (2) If I downloaded openSSL source and compile it by myself (I have to do
> this in order to avoid a name comflict of libeay32.dll with another
> product), I can compile the source without any problem, but I will get
> compilation errors when I try to compile rampart/c (axis2/c went fine). I
> tried openSSL-0.9.8.h and openSSL-0.9.8i, same problem. The error messages
> are like the following:
>
> C:\OpenSSL\include\openssl\x509.h(207) : error C2059: syntax error : 'type'
> C:\OpenSSL\include\openssl\x509.h(929) : error C2059: syntax error : 'type'
> C:\OpenSSL\include\openssl\x509.h(929) : error C2143: syntax error :
> missing ')' before '('
> C:\OpenSSL\include\openssl\x509.h(929) : error C2143: syntax error :
> missing ')' before '('
> C:\OpenSSL\include\openssl\x509.h(929) : error C2091: function returns
> function
> C:\OpenSSL\include\openssl\x509.h(929) : error C2091: function returns
> function
>  .....
>
> I noticed that the x509.h from my own build is different from the one in
> the downloaded binary version (attached in this message).
>
> The commands I used to compile the openSSL source is copied from the file
> INSTALL.W32, specifically as the following:
>
> (1) perl Configure VC-WIN32 --prefix=c:/openssl/dir
> (2) ms\do_ms
> (3) nmake -f ms\ntdll.mak
> (4) nmake -f ms\ntdll.mak install
>
>  Any clues what I am getting the compilation errors?
>
> Thanks much in advance.
>
> Raymond
>
>


-- 
S.Uthaiyashankar
Software Architect
WSO2 Inc.
http://wso2.com/ - "The Open Source SOA Company"

Mime
View raw message