axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Atanacio Reyes <arey...@yahoo.com>
Subject problems with apache2 (500 Internal Server Error)
Date Tue, 13 Jan 2009 03:12:48 GMT
Hi:
I was using axis2c 1.1 version without problems. But I tried install axis2c 1.5. when I enter
the Url: http://localhost/axis in my browser I get the error "500 Internal Server Error, The
server encountered an unexpected condition which prevented it from fulfilling the request."
the configuration for Apache is the same as axis2c version 1.1 as follow:

Axis2RepoPath /usr/local/axis2c
Axis2LogFile /usr/local/axis2c/logs/axis2http.log
Axis2LogLevel debug
Axis2ServiceURLPrefix / 
<Location /axis>
    SetHandler axis2_module
</Location>

last output from axis2http.log:
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/sg_math/libdiv.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/notify/libnotify.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/sg_math/libadd.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/Calculator/libCalculator.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/math/libmath.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/sg_math/libsub.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/mtom/libmtom.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/sg_math/libmul.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [debug] class_loader.c(140) /usr/local/axis2c/services/echo/libecho.so
shared lib loaded successfully
[Mon Jan 12 18:42:23 2009] [info]  [Axis2] Axis2 worker created
[Mon Jan 12 18:42:29 2009] [debug] apache2_worker.c(199) http://localhost/axis
[Mon Jan 12 18:42:29 2009] [debug] apache2_worker.c(229) Client HTTP version HTTP/1.1

output from apache2 error.log:
[Mon Jan 12 18:42:23 2009] [notice] Apache/2.2.8 (Ubuntu) Axis2C/1.5.0 configured -- resuming
normal operations

output from apache2 access.log:
127.0.0.1 - - [12/Jan/2009:18:54:54 -0800] "GET /axis HTTP/1.1" 500 210 "-" "Mozilla/5.0 (X11;
U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121621 Ubuntu/8.04 (hardy) Firefox/3.0.5"



      

Mime
View raw message