axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cha...@pacific.net.sg
Subject Re: Memory Leak when performing Load Test
Date Tue, 20 Jan 2009 15:36:15 GMT
i compiled using the following:

./configure --enable-guththila=yes
make
make install

but it seems that libxml2 is still the parser being used.
how should I enable the guththila parser ?


Quoting Manjula Peiris <manjula@wso2.com>:

> Some of the memory leaks are due to libxml2. Try with Guththila xml
> parser. Stub related memory leaks may need to be fixed. Please create a
> JIRA issue for that. Please attach the WSDL if you can.
>
>
> On Sun, 2009-01-18 at 13:52 -0800, chankm wrote:
>> Attached please find the valgrind trace for the memory leak problem.
>>
>> >Can you send the traces of the memory leaks ?
>> >
>> >On Sun, 2009-01-18 at 09:42 -0800, chankm wrote:
>> > > I have a web service client that uses svn Revision 735487 of Axis2c
>> > > to send SOAP request and receive SOAP response from a web   
>> service Server.
>> > >
>> > > the client sent the requests at the rate of 3 requests per second.
>> > > when I used pmap to check
>> > > the memory used by the client process, it showed that the memory
>> > > increases monotonically as long as the client
>> > > is sending the SOAP requests. After stopping the client, the memory
>> > > did not reduce to its original value when the test started. This
>> > > clearly showed a memory leak scenario.
>> > >
>> > > Even at 1 SOAP request per second, there is memory leak. The rate of
>> > > increase of
>> > > memory usage is slower in this case.
>> > >
>> > > The same problem happened when using Axis2c version 1.5 or 1.4
>> > >
>> > > Can anyone help me on this ?
>> > >
>> > > Thank you.
>> > >
>> > >
>
>




Mime
View raw message