axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manjula Peiris <manj...@wso2.com>
Subject Re: axis2_stub_free don't clear all env reference
Date Tue, 27 Jan 2009 16:19:56 GMT
Do you creating any axutil_hash and calling the function
axutil_hash_set_env ()? May be you are not freeing these hash.

Thanks,
-Manjula.


On Mon, 2009-01-12 at 10:49 +0100, Simone Bordin wrote:
> Hi,
> i'm using axis2c-1.5.0.
> 
> I have found this problem with the stub of a service:
> 
> - I created the axis2_env_t variable with the function
> axutil_env_create_all()
> - Then I created the stub for the service with the method
> axis2_stub_create_XXXXXX (this is the function generated from the
> WSDL2C tool for my service)
> - Then I called the operation (but this is not necessary)
> 
> At the end I needed to clear the stub and env variables. Here is the
> problem!
> 
> - After the call to the function axis2_stub_free(stub, env) not all
> the reference in the env variable are cleared. The env->ref field of
> the variable have value 41 and not 1.
> - In this way when the function axutil_env_free(env) is called, the
> variable is not cancelled because the reference counter doesn't have
> value 0.
> 
> This is a problem because it is a memory leak and because the log file
> of axis2, associated to the env variable, is not closed (so the
> process "loses" a file descriptor).
> 
> Is this a known problem?
> Thanx,
> simone bordin
> 
> 
> 
> -- 
> 
> 
> simone bordin
> developer
> 
> spazio zerouno spa
> via brescia 47 - 20063 cernusco s/n (mi)
> Tel. +39.02927314.1
> Fax. +39.02927314.211
> 
> 


Mime
View raw message