axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manjula Peiris <manj...@wso2.com>
Subject Re: ds:Refence URI not Encripted
Date Fri, 23 Jan 2009 03:29:58 GMT
Check the policy in your server side and compare for any mismatch.
BTW, this list is for Axis2/C and related project users. you may get a
better answer by posting to Rampart (Java) list.


On Thu, 2009-01-22 at 18:28 -0500, m4rkuz wrote:
> Hi Everyone,
> 
> I'm new to Axis2 and Rampart, but I need to do something very easy
> with them and haven't been able to do it..
> 
> The main problem is that I'm just to newbie at this, but for what I've
> learn I had seen the problem described below...
> 
> I need to consume a WebService that only needs to be signed, I have
> trayed the onlySing example for rampart but I keep getting:
> 
> FAULT MESSAGE: An unsupported token was provided
> 
> Somebody has a working client made with the oracle suit, (I Cannot use
> that) and send me an example soap message, comparing the two I only
> see one diference
> 
> Mine:
> ...
> <ds:Reference URI="#Id-20736546">
> ...
> <ds:Reference URI="#Timestamp-16437003">
> 
> the working one:
> ....
> <dsig:Reference URI="#bcyKqLafyGSUXDbAEVXbIg22">
> ...
> <dsig:Reference URI="#5KdQ0TRTux484dTYM5mpHQ22">
> 
> 
> how can I do to encript that URI ???
> 
> I had attached the policy file..
> 
> any Ideas??
> 
> 
> 
> Cordialmente,
> 
> 
> Marcus V. Sánchez D.
> ______________________
> Enterprise Developer.
> Sun Certified Java Programmer (SCJP)


Mime
View raw message