axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <sam...@wso2.com>
Subject Re: Axis2/C stripping SOAP faults in logs?
Date Fri, 19 Dec 2008 02:30:22 GMT
Have you engaged logging module?

Samisa...

Sérgio Gomes wrote:
> Bump. Has anyone come across this issue before?
>
> --Sérgio
>
> ---
> On Tue, Dec 16, 2008 at 16:48, Sérgio Gomes <sgomes@google.com> wrote:
>   
>> Hi there,
>>
>> Looks like every time I get a SOAP fault back from a service, using my
>> Axis2/C client (ADB generated stubs), the log comes out empty, e.g.:
>>
>> [Tue Dec 16 16:37:47 2008] [info]  Input message: <soapenv:Envelope
>> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
>> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>> xmlns:xsd="http://www.w3.org/2001/XMLSchema">
>>  <soapenv:Body>
>>  <soapenv:Fault>
>>   </soapenv:Fault>
>>  </soapenv:Body>
>> </soapenv:Envelope>
>>
>> Those SOAP faults are obviously not returned empty by the server, but
>> it seems that Axis doesn't make the contents of the Fault tag
>> available in the logs, for whatever reason. Is there any flag or
>> axis2.xml option I should change in order to get this?
>>
>> Thanks!
>>
>> Cheers,
>> Sérgio
>>
>> ---
>> Sérgio Gomes
>> Developer Relations
>>
>> Google | Gordon House | Barrow Street | Dublin 4 | Ireland
>> Registered in Dublin, Ireland | Registration Number: 368047
>>     
> >
> ------------------------------------------------------------------------
>
>
> No virus found in this incoming message.
> Checked by AVG - http://www.avg.com 
> Version: 8.0.176 / Virus Database: 270.9.19/1854 - Release Date: 12/17/2008 7:21 PM
>
>   


-- 
Samisa Abeysinghe 
Director, Engineering; WSO2 Inc.

http://www.wso2.com/ - "The Open Source SOA Company"


Mime
View raw message