axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Uthaiyashankar <shan...@wso2.com>
Subject Re: Axis2C response - valid xml document but nodes missing
Date Mon, 03 Nov 2008 06:36:53 GMT
Hi Xandi,

There are no such restriction AFAIK. Can you send the following to 
investigate the problem?
(1) capture the request and reply using tcpmon and attach the messages
(2) output of axiom_node_to_string or returned node.
(3) complete code of how you are accessing the returned node

Regards,
Shankar.

xandi wrote:
> Hi,
>
> I'm using axis2c_1.4.0 on Solaris. I created a client that uses SSL. Usually
> I have no problems sending request and receiving responses and decode them. 
>
> But then there is a strange effect: The Axis2C client does not throw an
> error and creates a response node that represents a valid xml document. But
> despite this it contains not all elements. They get lost without any error
> message. I verified that they were sent by the server. So why do they get
> lost?
>
> First I call this method:
>
> out_node = axis2_svc_client_send_receive(svc_client, env, in_node);
>
> Subsequently I try to transform the node to a string
>
> axiom_node_t* in_node_c2 = axiom_node_get_first_child(out_node, env);
> ACE_DEBUG((LM_DEBUG, " %s\n", axiom_node_to_string(in_node_c2, env)));
>
> This string is to short and when I try to traverse through the xml structure
> using 
>
> children_iter = axiom_element_get_children(om_ele, env, out_node);
>
> or similar methods it loops correctly through the structure but still has
> not enough elements.
>
> Is there any buffer limit or something I could modify in order to prevent
> losing nodes? How can I make sure that axis2c client has enough memory to
> process the response?
>
> Is it possible that it has to do with the encoding? 
>
> What can I do to solve the problem?
>
> Thanks a lot in advance for any help.
>
> Regards
>
> Xandi
>
>   


-- 
S.Uthaiyashankar
Software Architect
WSO2 Inc. 
http://wso2.com/ - "The Open Source SOA Company" 


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message