axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandro Javiel" <scjav...@gmail.com>
Subject Re: deploy of sample using axis2c
Date Wed, 01 Oct 2008 12:36:25 GMT
Hi Rajika,


2008/10/1 Rajika Kumarasiri <rajikacc@gmail.com>

>
>
> On Wed, Oct 1, 2008 at 12:32 AM, Sandro Javiel <scjaviel@gmail.com> wrote:
>
>> Hi all,
>>
> Hi,
> Did you follow the guidelines in the manual when deploying services with
> Apache? Did you specify the services folder in httpd.conf ? You can look
> into the axis2.log and the httpd.log to look into further information about
> the error.
>

Yes I follow  carefully the instructions from INSTALL file (available from
/usr/local/axis2c-bin-1.5.0-linux )


>
>> I am trying to deploy a c++ based webservice with axis2c-1.5.0 integrated
>> with apache-2.2.
>> Although the libraries and other files (as xml and wsdl) are created and
>> deployed to /usr/local/axis2c/services/<myWS>
>> I could not connect over the address http://<host>/services/<myWS>. I
>> noticed that the Calculator example (found in sample/server) could not be
>> connect when I changed the address "ws.apache.org" by "localhost".
>>
>
> BTW, what you mean by this ? Where did you change the address ?
>
The goal is to provide a WS with wsdl and SOAP to partners. Thus, I first
copied Calculator.wsdl file from
 /usr/local/axis2c-bin-1.5.0-linux/samples/server/Calculator/
to /usr/local/axis2c-bin-1.5.0-linux/samples/server/<myWS> changing the
operations.
Notice that the apache integration seems to be fine since I can browse page
http://<myServer>/axis2/services/ <http://192.168.0.11/axis2/services/>
and http://<myServer>/axis2/services/Calculator?wsdl<http://192.168.0.11/axis2/services/Calculator?wsdl>
 if the reference "ws.apache.org" is preserved on wsdl file.



-- 
Sandro Caldeira Javiel
+55 51 3076.1235

Mime
View raw message