axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "donald yang" <donal...@googlemail.com>
Subject How to set the content type of SOAP request to TEXT/XML
Date Tue, 21 Oct 2008 16:21:40 GMT
Hi All,

Currently I have a problem to call a .NET web service from a web service
client written using AXIS2C-1.4. I received an error that the .NET web
service expect that the content type of SOAP request should be TEXT/XML. But
the content type of the soap request created by AXIS2C-1.4 is
"multipart/related" [1].

I have searched the internet for a solution. Someone suggest to set the soap
version to 1.1. I tried that, but I still get the same problem. I also try
to disable MTOM. It is also not helpful.  If someone knows the solution,
could you please give me a hand? Many thanks in advance.


[1] SOAP request

POST /length.asmx HTTP/1.1
User-Agent: Axis2C/1.4.0
SOAPAction: "http://www.webserviceX.NET/ChangeLengthUnit"
Content-Length: 622
Content-Type: multipart/related;
boundary=MIMEBoundary7ba08b56-9d06-4203-b239-558681ae2d6d;
type="application/xop+xml"; start="<
0.33f98b1e-b723-4f4f-a738-071fc3267bd7@apache.org>"; start-info="text/xml";
charset="UTF-8"
Host: www.webservicex.net:9000

--MIMEBoundary7ba08b56-9d06-4203-b239-558681ae2d6d
content-transfer-encoding: binary
content-id: <0.33f98b1e-b723-4f4f-a738-071fc3267bd7@apache.org>content-type:
application/xop+xml;charset=UTF-8;type="text/xml";
   <soapenv:Envelope xmlns:soapenv="
http://schemas.xmlsoap.org/soap/envelope/">
      <soapenv:Header/>
      <soapenv:Body>
         <ns1:ChangeLengthUnitSoapIn xmlns:ns1="http://www.webserviceX.NET/
">
            <LengthValue>20.0</LengthValue>
            <fromLengthUnit>Meters</fromLengthUnit>
            <toLengthUnit>Millimeters</toLengthUnit>
         </ns1:ChangeLengthUnitSoapIn>
      </soapenv:Body>
   </soapenv:Envelope>--MIMEBoundary7ba08b56-9d06-4203-b239-558681ae2d6d--

Mime
View raw message