axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <sam...@wso2.com>
Subject Re: RE : RE : Axis2/C built with SSL support. axis2_http_sender.dll fails to load
Date Fri, 10 Oct 2008 01:41:29 GMT
What are the http headers being sent in the request? Specially, what is 
the content type?

Samisa...

Laksh wrote:
> Hi,
>
> There are no attachments MTOM optimized with mime_headers.
>
> The response returned by the webservice and also the sniffer running on the
> test machine found is
>  
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
> xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" 
> xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
> <soapenv:Header/>
> <soapenv:Body>
> <soapresponse>
> 	<temptag>abc</temptag>
> 	<set>
> 		<data/>
> 		<data/>
> 		<data name="id">testreturn_value</data>
> 		<data name="name">Micky</data>
> 	</set>
> 	</soapresponse>
> </soapenv:Body>
> </soapenv:Envelope>
>
> Anything wrong in this? Any help will be greatly useful.
>
> Thanks!
> Laksh
>
>
> Manjula Peiris wrote:
>   
>> Can you send us the SOAP response ? And is it contains attachments MTOM
>> optimized with mime_headers ?
>>
>> On Thu, 2008-10-09 at 02:42 -0700, Laksh wrote:
>>     
>>> Hi,
>>>
>>> Now most of the problems I was facing were resolved.
>>>
>>> 1) I wasn't setting the SERVER_CERT properly. Now I am just getting the
>>> output of the command provided in the Axis2/C doc to get the server
>>> certificate and putting it in the a .pem file. (no key-cert pair in the
>>> file
>>> though)
>>> 2) I have built OpenSSL with the different name for the libraries and
>>> built
>>> Axis2/C with the modifed libraries. Now http_sender.dll is able to load
>>> and
>>> works fine. Using the same openssl libraries as Websphere didn't work at
>>> all.
>>>
>>> After these two change now SOAP client is working fine in two of the
>>> envionments. When we moved to a another environment we are getting "AXIS
>>> Error Code: 188, Error Message: SOAP message does not contain a SOAP
>>> envelope element" error in axis2_svc_client_send_receive() call. The
>>> webservice we are connecting now is different but it is returning a valid
>>> SOAP envelope.
>>>
>>> What could be the issue here? 
>>>
>>> We are setting SOAP1.1 version in the svc_client and the webservice we
>>> are
>>> sending request to does not support SOAP1.2. 
>>>
>>> Any pointers regarding this issue will be very helpful.
>>>
>>> Thanks!
>>> Laksh
>>>
>>>
>>> Laksh wrote:
>>>       
>>>> Hi,
>>>>
>>>> I am wondering whether the SERVER_CERT specified in axis2.xml cause of
>>>> this issue. We are not interested in enabling client authentication. So
>>>>         
>>> my
>>>       
>>>> doubts are
>>>> 1) Do I need to provide SERVER_CERT in axis2.xml? We are not interested
>>>>         
>>> in
>>>       
>>>> setting up client authentication
>>>> 2) If this is required, what should be the value? Can I generate a
>>>> self-signed certificate to get the .pem file?
>>>> 3) IBM Websphere doesn't allow exporting private key to create .pem
>>>>         
>>> file.
>>>       
>>>> Is it really neccessary to do this if we are not doing client
>>>> authentication?
>>>>
>>>> Will these configurations affect loading of axis2_http_sender.dll? The
>>>> error I get is "DLERROR IS DLL Load Error 182"
>>>>
>>>> The openssl DLL's are in path and there is single version of openssl
>>>>         
>>> dll
>>>       
>>>> in the test machine. Also dependency walker doesn't show any errors in
>>>> finding the dll's.
>>>>
>>>> Any clarification on will be veru much helpful.
>>>>
>>>> Thanks!
>>>> Laksh
>>>>
>>>>
>>>> Laksh wrote:
>>>>         
>>>>> Hi,
>>>>>
>>>>> I am looking into debugging this issue and fix if possible.
>>>>>
>>>>> Which method will be called when axis2_http_sender.dll is loaded? I am
>>>>> not finding DLLmain() method anywhere in the source files, is there
>>>>>           
>>> any
>>>       
>>>>> other method I can look into?
>>>>>
>>>>> Does the axis2_ssl_utils_initialize_ctx() called when SSL support is
>>>>> enabled? It is calling SSL_library_init() etc...
>>>>>
>>>>> Any help in this is will be of immense help.
>>>>>
>>>>> Thanks!
>>>>> Laksh
>>>>>
>>>>>
>>>>> Laksh wrote:
>>>>>           
>>>>>> Hi,
>>>>>>
>>>>>> I could find the working openssl version for IBM Websphere and built
>>>>>> Axis2/C with that version. It is using 0.9.6m version and now all
the
>>>>>> openssl dll's in the test environment are the same.
>>>>>>
>>>>>> Still I am getting the axis2_http_sender.dll load error, though the
>>>>>> error number is changed from 126 to 182. Below is the trace.
>>>>>>
>>>>>> Fri Oct 03 14:48:35 2008] [debug] ..\..\src\core\engine\phase.c(121)
>>>>>> axis2_handler_t *context_handler added to the index 1 of the phase
>>>>>> PostDispatch
>>>>>> [Fri Oct 03 14:48:35 2008] [debug]
>>>>>> ..\..\src\core\deployment\conf_builder.c(233) No custom dispatching
>>>>>> order found. Continue with the default dispatching order
>>>>>> [Fri Oct 03 14:48:35 2008] [debug]
>>>>>> ..\..\src\core\deployment\conf_builder.c(378) Module addressing found
>>>>>>             
>>> in
>>>       
>>>>>> axis2.xml
>>>>>> [Fri Oct 03 14:48:35 2008] [error] ..\..\util\src\class_loader.c(167)
>>>>>> Loading shared library C:\Apache
>>>>>>             
>>> Group\Axis2C/lib/axis2_http_sender.dll 
>>>       
>>>>>> Failed. DLERROR IS DLL Load Error 182: 
>>>>>> [Fri Oct 03 14:48:35 2008] [error]
>>>>>> ..\..\src\core\deployment\conf_builder.c(898) Transport sender is
>>>>>>             
>>> NULL
>>>       
>>>>>> for transport http, unable to continue
>>>>>> [Fri Oct 03 14:48:35 2008] [error]
>>>>>> ..\..\src\core\deployment\conf_builder.c(261) Processing transport
>>>>>> senders failed, unable to continue
>>>>>> [Fri Oct 03 14:48:35 2008] [error]
>>>>>> ..\..\src\core\deployment\dep_engine.c(939) Populating Axis2
>>>>>> Configuration failed
>>>>>> [Fri Oct 03 14:48:35 2008] [error]
>>>>>> ..\..\src\core\deployment\conf_init.c(195) Loading deployment engine
>>>>>> failed for client repository C:\Apache Group\Axis2C
>>>>>>
>>>>>> Any ideas why this can happen? I have checked by enabling SSL in
>>>>>> Axis2.xml as well. It is giving the error.
>>>>>>
>>>>>> Thanks!
>>>>>> Laksh
>>>>>>
>>>>>>
>>>>>> Supun Kamburugamuva wrote:
>>>>>>             
>>>>>>> How about copying the matching DLL to the axis2c lib directory
where
>>>>>>> axis2_http_sender.dll is in?
>>>>>>>
>>>>>>> Supun..
>>>>>>>
>>>>>>> On Fri, Oct 3, 2008 at 6:10 PM, Laksh <
>>>>>>> lakshminarayana.ullala@friendsprovident.co.uk> wrote:
>>>>>>>
>>>>>>>               
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> IBM Websphere ships openssl dll libeay32.dll(808 KB) and
the app
>>>>>>>> server
>>>>>>>> doesn't start with any other version of this DLL. I am not
able to
>>>>>>>> find the
>>>>>>>> version of openssl from the DLL present there. I have tried
>>>>>>>>                 
>>> building
>>>       
>>>>>>>> Axis2/C
>>>>>>>> with most of the versions of OpenSSL but not able to get
the
>>>>>>>> axis2_http_sender.dll to load in Websphere environment.
>>>>>>>>
>>>>>>>> Is there any way we can resolve this DLL conflicts? Any pointers
>>>>>>>>                 
>>> will
>>>       
>>>>>>>> be of
>>>>>>>> great help.
>>>>>>>>
>>>>>>>> Thanks in advance
>>>>>>>>
>>>>>>>> Laksh
>>>>>>>>
>>>>>>>>
>>>>>>>> Lefrancois, Carl wrote:
>>>>>>>>                 
>>>>>>>>> Hi Laksh,
>>>>>>>>>
>>>>>>>>> Good luck debugging this problem!  This is probably not
helpful,
>>>>>>>>>                   
>>> but
>>>       
>>>>>>>> it
>>>>>>>> is
>>>>>>>>                 
>>>>>>>>> true that LoadLibrary will check the C:\ directory first
before
>>>>>>>>>                   
>>> all
>>>       
>>>>>>>> other
>>>>>>>>                 
>>>>>>>>> places and load a DLL from there if it finds one.  (even
if C:\
>>>>>>>>>                   
>>> is
>>>       
>>>>>>>> not in
>>>>>>>>                 
>>>>>>>>> the path)
>>>>>>>>>
>>>>>>>>> It sounds like you are on the right track because the
dependency
>>>>>>>>>                   
>>>>>>>> checker
>>>>>>>>                 
>>>>>>>>> will report all the necessary DLLs are there even if
one of the
>>>>>>>>>                   
>>>>>>>> necessary
>>>>>>>>                 
>>>>>>>>> DLLs is the wrong version.
>>>>>>>>>
>>>>>>>>> Carl
>>>>>>>>>
>>>>>>>>> -----Message d'origine-----
>>>>>>>>> De : Laksh [mailto:lakshminarayana.ullala@friendsprovident.co.uk]
>>>>>>>>> Envoyé : jeudi, octobre 2, 2008 16:46
>>>>>>>>> À : axis-c-user@ws.apache.org
>>>>>>>>> Objet : Re: RE : Axis2/C built with SSL support.
>>>>>>>>>                   
>>>>>>>> axis2_http_sender.dll
>>>>>>>>                 
>>>>>>>>> fails to load
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Hi,
>>>>>>>>>
>>>>>>>>> I have checked all the dependent DLL's as shown in the
dependency
>>>>>>>>>                   
>>>>>>>> checker.
>>>>>>>>                 
>>>>>>>>> All the DLL's are in the path.
>>>>>>>>>
>>>>>>>>> Samisa asked me to check duplicate openssl libraries
in the path.
>>>>>>>>>                   
>>> I
>>>       
>>>>>>>> have
>>>>>>>>                 
>>>>>>>>> found that there is another openssl library in the system
which
>>>>>>>>>                   
>>> is
>>>       
>>>>>>>> used
>>>>>>>> by
>>>>>>>>                 
>>>>>>>>> IBM GSKit. This could be the problem for Axis DLL's not
loading.
>>>>>>>>>                   
>>> The
>>>       
>>>>>>>>> version of openssl DLL packaged with IBM GSkit seems
to be old
>>>>>>>>>                   
>>> and I
>>>       
>>>>>>>> have
>>>>>>>>                 
>>>>>>>>> compiled Axis2/C using the latest version of Open SSL.
I am
>>>>>>>>>                   
>>> trying
>>>       
>>>>>>>> to see
>>>>>>>>                 
>>>>>>>>> if I can get Axis2/C compiled with the same version and
test
>>>>>>>>>                   
>>> again.
>>>       
>>>>>>>> I
>>>>>>>> have
>>>>>>>>                 
>>>>>>>>> tries with few other openssl versions till now but not
found the
>>>>>>>>>                   
>>>>>>>> working
>>>>>>>>                 
>>>>>>>>> solution. Maybe there is something else stopping the
>>>>>>>>>                   
>>>>>>>> axis2_http_sender.dll
>>>>>>>>                 
>>>>>>>>> DLL to load.
>>>>>>>>>
>>>>>>>>> Please let me know if there are any other cause for this
error.
>>>>>>>>>
>>>>>>>>> Thanks!
>>>>>>>>> Laksh
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Lefrancois, Carl wrote:
>>>>>>>>>                   
>>>>>>>>>> I believe LoadLibrary on Windows uses the path environment
>>>>>>>>>>                     
>>> variable
>>>       
>>>>>>>> to
>>>>>>>>                 
>>>>>>>>>> attempt to find the dependencies of the DLL.  Is
your SLL DLL in
>>>>>>>>>>                     
>>> a
>>>       
>>>>>>>>>> directory that is referenced in your path?
>>>>>>>>>>
>>>>>>>>>> Carl Lefrançois
>>>>>>>>>> Analyste / Programmeur
>>>>>>>>>> Larochelle Groupe Conseil
>>>>>>>>>>
>>>>>>>>>> Tél. :      514-282-6817, poste 4548
>>>>>>>>>> Couriel : carl.lefrancois@axa-canada.com
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> -----Message d'origine-----
>>>>>>>>>> De : Laksh
>>>>>>>>>>                     
>>> [mailto:lakshminarayana.ullala@friendsprovident.co.uk]
>>>       
>>>>>>>>>> Envoyé : jeudi, octobre 2, 2008 05:38
>>>>>>>>>> À : axis-c-user@ws.apache.org
>>>>>>>>>> Objet : Re: Axis2/C built with SSL support.
>>>>>>>>>>                     
>>> axis2_http_sender.dll
>>>       
>>>>>>>> fails
>>>>>>>>                 
>>>>>>>>>> to load
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Hi Samisa,
>>>>>>>>>>
>>>>>>>>>> Yes, I have set AXIS2C_HOME. The DLL path is showing
correctly
>>>>>>>>>>                     
>>> in
>>>       
>>>>>>>> the
>>>>>>>>                 
>>>>>>>>>> error message. Also if I use the non-ssl version
of
>>>>>>>>>> axis2_http_sender.dll, it works fine. But I need
SSL support as
>>>>>>>>>>                     
>>>>>>>> well.
>>>>>>>>                 
>>>>>>>>>> Thanks!
>>>>>>>>>> Laksh
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Samisa Abeysinghe-4 wrote:
>>>>>>>>>>                     
>>>>>>>>>>> Have you set the AXIS2C_HOME?
>>>>>>>>>>>
>>>>>>>>>>> Samisa...
>>>>>>>>>>>
>>>>>>>>>>> Laksh wrote:
>>>>>>>>>>>                       
>>>>>>>>>>>> Hi,
>>>>>>>>>>>>
>>>>>>>>>>>> I have built Axis2/C v1.5.0 with SSL support
on Windows. The
>>>>>>>>>>>>                         
>>>>>>>> client
>>>>>>>>                 
>>>>>>>>>>>> program we have developed connects to a web
service with SOAP
>>>>>>>>>>>> requests. The webservice is hosted on Websphere
Application
>>>>>>>>>>>> Server(WAS).  We have configured WAS for
SSL support. When the
>>>>>>>>>>>> axis2_svc_client_send_receive() call is made
by our SOAP
>>>>>>>>>>>>                         
>>> client
>>>       
>>>>>>>> the
>>>>>>>>                 
>>>>>>>>>>>> following error is logged in the client
>>>>>>>>>>>> log file.
>>>>>>>>>>>>
>>>>>>>>>>>> "../axis2_http_sender.dll  Failed. DLERROR
IS DLL Load Error
>>>>>>>>>>>>                         
>>> 126:
>>>       
>>>>>>>>>>>> The specified module could not be found."
>>>>>>>>>>>>
>>>>>>>>>>>> If I use the non-ssl version of axis2_http_sender.dll
then the
>>>>>>>>>>>>                         
>>>>>>>> error
>>>>>>>>                 
>>>>>>>>>>>> disappears. But we need to use the SSL enabled
version of
>>>>>>>>>>>>                         
>>> Axis2/C
>>>       
>>>>>>>>>>>> because sometime the webservice URL will
be https.
>>>>>>>>>>>>
>>>>>>>>>>>> What could be the reason for this error?
We have not done any
>>>>>>>>>>>>                         
>>> SSL
>>>       
>>>>>>>>>>>> specific configuration in Axis2.xml file.
Is there anything we
>>>>>>>>>>>>                         
>>>>>>>> need
>>>>>>>>                 
>>>>>>>>>>>> to do in that file?
>>>>>>>>>>>>
>>>>>>>>>>>> I have added SSL DLL's in the path, also
checked all the
>>>>>>>>>>>>                         
>>>>>>>> dependent
>>>>>>>>                 
>>>>>>>>>>>> DLL's are in path. There seems to be no path
issues.
>>>>>>>>>>>>
>>>>>>>>>>>> Any pointers to resovle this issue is greatly
appreciated.
>>>>>>>>>>>>
>>>>>>>>>>>> Thanks for your time.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>                         
>>> --------------------------------------------------------------------
>>>       
>>>>>>>>>>>> -
>>>>>>>>>>>> ---
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> No virus found in this incoming message.
>>>>>>>>>>>> Checked by AVG - http://www.avg.com
>>>>>>>>>>>> Version: 8.0.173 / Virus Database: 270.7.5/1702
- Release
>>>>>>>>>>>>                         
>>> Date:
>>>       
>>>>>>>>>> 10/1/2008
>>>>>>>>>>                     
>>>>>>>>>>>> 9:05 AM
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>                         
>>>>>>>>>>> --
>>>>>>>>>>> Samisa Abeysinghe
>>>>>>>>>>> Director, Engineering; WSO2 Inc.
>>>>>>>>>>>
>>>>>>>>>>> http://www.wso2.com/ - "The Open Source SOA Company"
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>                       
>>> ---------------------------------------------------------------------
>>>       
>>>>>>>>>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>>>>>>>>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>                       
>>>>>>>>>> --
>>>>>>>>>> View this message in context:
>>>>>>>>>>
>>>>>>>>>>                     
>>> http://www.nabble.com/Axis2-C-built-with-SSL-support.-axis2_http_sender
>>>       
>>>>>>>> .
>>>>>>>>                 
>>>>>>>>>> dll-fails-to-load-tp19776097p19776260.html
>>>>>>>>>> Sent from the Axis - C++ - User mailing list archive
at
>>>>>>>>>>                     
>>> Nabble.com.
>>>       
>>>>>>>>>>
>>>>>>>>>>                     
>>> ---------------------------------------------------------------------
>>>       
>>>>>>>>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>>>>>>>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>>>>>>>>   _____
>>>>>>>>>>
>>>>>>>>>> "Ce message est confidentiel, à l'usage exclusif
du destinataire
>>>>>>>>>> ci-dessus et son contenu ne représente en aucun
cas un
>>>>>>>>>>                     
>>> engagement
>>>       
>>>>>>>> de
>>>>>>>>                 
>>>>>>>>>> la part de AXA, sauf en cas de stipulation expresse
et par écrit
>>>>>>>>>>                     
>>> de
>>>       
>>>>>>>> la
>>>>>>>>                 
>>>>>>>>>> part de AXA. Toute publication, utilisation ou diffusion,
même
>>>>>>>>>> partielle, doit être autorisée préalablement.
Si vous n'êtes pas
>>>>>>>>>> destinataire de ce message, merci d'en avertir immédiatement
>>>>>>>>>> l'expéditeur."
>>>>>>>>>>
>>>>>>>>>> "This e-mail message is confidential, for the exclusive
use of
>>>>>>>>>>                     
>>> the
>>>       
>>>>>>>>>> addressee and its contents shall not constitute a
commitment by
>>>>>>>>>>                     
>>>>>>>> AXA,
>>>>>>>>                 
>>>>>>>>>> except as otherwise specifically provided in writing
by AXA. Any
>>>>>>>>>> unauthorized disclosure, use or dissemination, either
whole or
>>>>>>>>>> partial, is prohibited. If you are not the intended
recipient of
>>>>>>>>>>                     
>>>>>>>> the
>>>>>>>>                 
>>>>>>>>>> message, please notify the sender immediately."
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>                     
>>> ---------------------------------------------------------------------
>>>       
>>>>>>>>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>>>>>>>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>                     
>>>>>>>>> --
>>>>>>>>> View this message in context:
>>>>>>>>>
>>>>>>>>>                   
>>> http://www.nabble.com/Axis2-C-built-with-SSL-support.-axis2_http_sender.dll-fails-to-load-tp19776097p19787293.html
>>>       
>>>>>>>>> Sent from the Axis - C++ - User mailing list archive
at
>>>>>>>>>                   
>>> Nabble.com.
>>>       
>>>>>>>>>
>>>>>>>>>                   
>>> ---------------------------------------------------------------------
>>>       
>>>>>>>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>>>>>>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>                   
>>> ---------------------------------------------------------------------
>>>       
>>>>>>>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>>>>>>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>                   
>>>>>>>> --
>>>>>>>> View this message in context:
>>>>>>>>
>>>>>>>>                 
>>> http://www.nabble.com/Axis2-C-built-with-SSL-support.-axis2_http_sender.dll-fails-to-load-tp19776097p19797442.html
>>>       
>>>>>>>> Sent from the Axis - C++ - User mailing list archive at Nabble.com.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>                 
>>> ---------------------------------------------------------------------
>>>       
>>>>>>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>>>>>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>>>>>>
>>>>>>>>
>>>>>>>>                 
>>>>>>> -- 
>>>>>>> Software Engineer, WSO2 Inc
>>>>>>> http://wso2.org
>>>>>>>
>>>>>>>
>>>>>>>               
>>>>>>             
>>>>>           
>>>>         
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>
>>
>>
>>     
>
>   
> ------------------------------------------------------------------------
>
>
> No virus found in this incoming message.
> Checked by AVG - http://www.avg.com 
> Version: 8.0.173 / Virus Database: 270.7.6/1715 - Release Date: 10/8/2008 7:19 PM
>
>   


-- 
Samisa Abeysinghe 
Director, Engineering; WSO2 Inc.

http://www.wso2.com/ - "The Open Source SOA Company"


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message