axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <sam...@wso2.com>
Subject Re: Axis2/C built with SSL support. axis2_http_sender.dll fails to load
Date Thu, 02 Oct 2008 09:33:04 GMT
Have you set the AXIS2C_HOME?

Samisa...

Laksh wrote:
> Hi,
>
> I have built Axis2/C v1.5.0 with SSL support on Windows. The client program
> we have developed connects to a web service with SOAP requests. The
> webservice is hosted on Websphere Application Server(WAS).  We have
> configured WAS for SSL support. When the axis2_svc_client_send_receive()
> call is made by our SOAP client the following error is logged in the client
> log file.
>
> "../axis2_http_sender.dll  Failed. DLERROR IS DLL Load Error 126: The
> specified module could not be found."
>
> If I use the non-ssl version of axis2_http_sender.dll then the error
> disappears. But we need to use the SSL enabled version of Axis2/C because
> sometime the webservice URL will be https.
>
> What could be the reason for this error? We have not done any SSL specific
> configuration in Axis2.xml file. Is there anything we need to do in that
> file?
>
> I have added SSL DLL's in the path, also checked all the dependent DLL's are
> in path. There seems to be no path issues.
>
> Any pointers to resovle this issue is greatly appreciated. 
>
> Thanks for your time.
>
>
>
>   
> ------------------------------------------------------------------------
>
>
> No virus found in this incoming message.
> Checked by AVG - http://www.avg.com 
> Version: 8.0.173 / Virus Database: 270.7.5/1702 - Release Date: 10/1/2008 9:05 AM
>
>   


-- 
Samisa Abeysinghe 
Director, Engineering; WSO2 Inc.

http://www.wso2.com/ - "The Open Source SOA Company"


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message