axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laksh <lakshminarayana.ull...@friendsprovident.co.uk>
Subject Re: Axis2/C built with SSL support. axis2_http_sender.dll fails to load
Date Thu, 02 Oct 2008 10:15:36 GMT

Hi,

I have downloaded Axis2/C source version and compiled with SSL enabled. Also
I have download the Axis2/C binary version which is not built with SSL
support.

OpenSSL v0.9.8, I have the same version in test and development environment. 

I have tested by configuring SSL in axis2.xml and now it proceeds further
and started showing different error. The errors logged in the log file is
below

[debug] ..\..\src\core\deployment\dep_engine.c(1042) No modules configured
[debug] ..\..\src\core\phaseresolver\phase_resolver.c(139) Service name is :
__ANONYMOUS_SERVICE__
[debug] ..\..\src\core\clientapi\op_client.c(881)
Start:axis2_op_client_infer_transport
[error] ..\..\src\core\clientapi\op_client.c(935) Cannot infer transport
[debug] ..\..\src\core\clientapi\op_client.c(940)
End:axis2_op_client_infer_transport
[error] ..\..\src\core\clientapi\op_client.c(407) Op client execute failed.
Cannot find transport out.

The configurations I have done in axis2.xml are as below

- Uncommented in transport Ins
<transportReceiver name="https" class="axis2_http_receiver">
        <parameter name="port" locked="false">6060</parameter>
        <parameter name="exposeHeaders" locked="true">false</parameter>
</transportReceiver>

- Uncommented in transport outs
<transportSender name="https" class="axis2_http_sender">
        <parameter name="PROTOCOL" locked="false">HTTP/1.1</parameter>
        <parameter name="xml-declaration" insert="false"/>
</transportSender>
<parameter name="SERVER_CERT">/path/to/ca/certificate</parameter>
<parameter
name="KEY_FILE">/path/to/client/certificate/chain/file</parameter>
<parameter name="SSL_PASSPHRASE">passphrase</parameter>

I have tried with the correct certificate parameters but it is giving the
same error.

What could be going wrong? 

Is there any binary version of Axis2/C with SSL support available for
download?

Thanks again for your help

Laksh


Samisa Abeysinghe-4 wrote:
> 
> So you must be using binary release, and your openssl version might be 
> different form what we have compiled against.
> 
> Samisa...
> 
> Laksh wrote:
>> Hi Samisa,
>>
>> Yes, I have set AXIS2C_HOME. The DLL path is showing correctly in the
>> error
>> message. Also if I use the non-ssl version of axis2_http_sender.dll, it
>> works fine. But I need SSL support as well.
>>
>> Thanks!
>> Laksh
>>
>>
>> Samisa Abeysinghe-4 wrote:
>>   
>>> Have you set the AXIS2C_HOME?
>>>
>>> Samisa...
>>>
>>> Laksh wrote:
>>>     
>>>> Hi,
>>>>
>>>> I have built Axis2/C v1.5.0 with SSL support on Windows. The client
>>>> program
>>>> we have developed connects to a web service with SOAP requests. The
>>>> webservice is hosted on Websphere Application Server(WAS).  We have
>>>> configured WAS for SSL support. When the
>>>> axis2_svc_client_send_receive()
>>>> call is made by our SOAP client the following error is logged in the
>>>> client
>>>> log file.
>>>>
>>>> "../axis2_http_sender.dll  Failed. DLERROR IS DLL Load Error 126: The
>>>> specified module could not be found."
>>>>
>>>> If I use the non-ssl version of axis2_http_sender.dll then the error
>>>> disappears. But we need to use the SSL enabled version of Axis2/C
>>>> because
>>>> sometime the webservice URL will be https.
>>>>
>>>> What could be the reason for this error? We have not done any SSL
>>>> specific
>>>> configuration in Axis2.xml file. Is there anything we need to do in
>>>> that
>>>> file?
>>>>
>>>> I have added SSL DLL's in the path, also checked all the dependent
>>>> DLL's
>>>> are
>>>> in path. There seems to be no path issues.
>>>>
>>>> Any pointers to resovle this issue is greatly appreciated. 
>>>>
>>>> Thanks for your time.
>>>>
>>>>
>>>>
>>>>   
>>>> ------------------------------------------------------------------------
>>>>
>>>>
>>>> No virus found in this incoming message.
>>>> Checked by AVG - http://www.avg.com 
>>>> Version: 8.0.173 / Virus Database: 270.7.5/1702 - Release Date:
>>>> 10/1/2008
>>>> 9:05 AM
>>>>
>>>>   
>>>>       
>>> -- 
>>> Samisa Abeysinghe 
>>> Director, Engineering; WSO2 Inc.
>>>
>>> http://www.wso2.com/ - "The Open Source SOA Company"
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>
>>>
>>>
>>>     
>>
>>   
>> ------------------------------------------------------------------------
>>
>>
>> No virus found in this incoming message.
>> Checked by AVG - http://www.avg.com 
>> Version: 8.0.173 / Virus Database: 270.7.5/1702 - Release Date: 10/1/2008
>> 9:05 AM
>>
>>   
> 
> 
> -- 
> Samisa Abeysinghe 
> Director, Engineering; WSO2 Inc.
> 
> http://www.wso2.com/ - "The Open Source SOA Company"
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Axis2-C-built-with-SSL-support.-axis2_http_sender.dll-fails-to-load-tp19776097p19776668.html
Sent from the Axis - C++ - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message