axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tammy Martin" <tammymartinc...@gmail.com>
Subject Rampart/C added on to Axis2c, axis2_http_server fails launch
Date Wed, 17 Sep 2008 00:06:10 GMT
Hello all,

I installed Rampart/C per instructions here:

http://ws.apache.org/rampart/c/docs/installationguide.html

and tried to run the samples via the axis2_http_server but the
axis2_http_server fails to start after the installation of Rampart/C.  I
found information that said to update to the latest OpenSSL I am currently
at version: OpenSSL 0.9.8i 15 Sep 2008. https://wso2.org/forum/thread/3454

Here is the error I have in the axis2.log:

[Tue Sep 16 17:03:47 2008] [info]  Starting Axis2 HTTP server....
[Tue Sep 16 17:03:47 2008] [info]  Apache Axis2/C version in use : 1.3.0
[Tue Sep 16 17:03:47 2008] [info]  Server port : 9090
[Tue Sep 16 17:03:47 2008] [info]  Repo location : ../
[Tue Sep 16 17:03:47 2008] [info]  Read Timeout : 60000 ms
[Tue Sep 16 17:03:47 2008] [debug] phase.c(121) axis2_handler_t
*request_uri_based_dispatcher added to the index 0 of the phase Transport
[Tue Sep 16 17:03:47 2008] [debug] phase.c(121) axis2_handler_t
*addressing_based_dispatcher added to the index 1 of the phase Transport
[Tue Sep 16 17:03:47 2008] [debug] phase.c(121) axis2_handler_t
*rest_dispatcher added to the index 0 of the phase Dispatch
[Tue Sep 16 17:03:47 2008] [debug] phase.c(121) axis2_handler_t
*soap_message_body_based_dispatcher added to the index 1 of the phase
Dispatch
[Tue Sep 16 17:03:47 2008] [debug] phase.c(121) axis2_handler_t
*soap_action_based_dispatcher added to the index 2 of the phase Dispatch
[Tue Sep 16 17:03:47 2008] [debug] phase.c(121) axis2_handler_t
*dispatch_post_conditions_evaluator added to the index 0 of the phase
PostDispatch
[Tue Sep 16 17:03:47 2008] [debug] phase.c(121) axis2_handler_t
*context_handler added to the index 1 of the phase PostDispatch
[Tue Sep 16 17:03:47 2008] [debug] conf_builder.c(233) no custom dispatching
order found continue with default dispatching order
[Tue Sep 16 17:03:47 2008] [debug] conf_builder.c(384) module addressing
found in axis2.xml
[Tue Sep 16 17:03:47 2008] [debug] class_loader.c(140) Object loaded
successfully
[Tue Sep 16 17:03:47 2008] [debug] class_loader.c(140) Object loaded
successfully
[Tue Sep 16 17:03:47 2008] [debug] dep_engine.c(1259)
axis2_dep_engine_load_module_dll: DLL path is :
..//modules/addressing/libaxis2_mod_addr.so
[Tue Sep 16 17:03:47 2008] [debug] class_loader.c(140) Object loaded
successfully
[Tue Sep 16 17:03:47 2008] [debug] dep_engine.c(1259)
axis2_dep_engine_load_module_dll: DLL path is :
..//modules/logging/libaxis2_mod_log.so
[Tue Sep 16 17:03:47 2008] [debug] class_loader.c(140) Object loaded
successfully
[Tue Sep 16 17:03:47 2008] [debug] dep_engine.c(1259)
axis2_dep_engine_load_module_dll: DLL path is :
..//modules/rampart/libmod_rampart.so
[Tue Sep 16 17:03:47 2008] [error] dep_engine.c(768) dep_engine repos
listener creation failed, folder name is ../
[Tue Sep 16 17:03:47 2008] [error] conf_init.c(67) dep engine load failed.
conf value is NULL
[Tue Sep 16 17:03:47 2008] [error] http_server_main.c(215) Server creation
failed: Error code: 34 :: Repository listener initialization failed

Please help I cannot run the Rampart/C examples...

Thank you.
Tammy

Mime
View raw message