axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graf László <gr...@datatrans.hu>
Subject dlerror reason: Something went wrong loading the DLL. If you happen to see this message, please note that getting the exact error form Windows is a TODO. And if possible please help fix it. :)
Date Sun, 17 Aug 2008 15:14:23 GMT
Hi all,

I downloaded the binary distribution of AXIS2C for MS Windows, version 
1.5.0. I unzipped it to the folder D:\axis2c\axis2c-bin-1.5.0-win32 and 
I made all the steps indicated in "3.2 Deploying in Apache2 Web Server" 
section of the Axis2C documentation.

The httpd.conf file contains the following lines:

LoadModule axis2_module modules/mod_axis2.so
Axis2RepoPath D:/axis2c/axis2c-bin-1.5.0-win32
Axis2LogFile D:/axis2c/axis2c-bin-1.5.0-win32/logs/axis2c.log
Axis2MaxLogFileSize 10
Axis2LogLevel DEBUG
<Location /axis2>
SetHandler axis2_module
</Location>

The start of Apache server failed and the httpd's error.log file 
contains these lines:

[Sun Aug 17 17:10:39 2008] [notice] Apache/2.2.9 (Win32) PHP/5.2.3 
Axis2C/1.5.0 configured -- resuming normal operations
[Sun Aug 17 17:10:39 2008] [notice] Server built: Jun 13 2008 04:04:59
[Sun Aug 17 17:10:39 2008] [notice] Parent: Created child process 456
[Sun Aug 17 17:10:39 2008] [debug] mpm_winnt.c(487): Parent: Sent the 
scoreboard to the child
[Sun Aug 17 17:10:39 2008] [notice] Child 456: Child process is running
[Sun Aug 17 17:10:39 2008] [info] Parent: Duplicating socket 200 and 
sending it to child process 456
[Sun Aug 17 17:10:39 2008] [debug] mpm_winnt.c(605): Parent: Sent 1 
listeners to child 456
[Sun Aug 17 17:10:39 2008] [debug] mpm_winnt.c(408): Child 456: 
Retrieved our scoreboard from the parent.
[Sun Aug 17 17:10:39 2008] [debug] mpm_winnt.c(564): Child 456: 
retrieved 1 listeners from parent
[Sun Aug 17 17:10:39 2008] [emerg] (20014)Internal error: [Axis2] Error 
creating mod_axis2 apache2 worker
[Sun Aug 17 17:10:39 2008] [crit] Parent: child process exited with 
status 15 -- Aborting.
[Sun Aug 17 17:10:39 2008] [info] removed PID file 
C:/Apache2.2.9/logs/httpd.pid (pid=3852)

The axis2c.log file's content is this:

[Sun Aug 17 17:10:39 2008] [info]  Apache Axis2/C version in use : 1.4.0
[Sun Aug 17 17:10:39 2008] [info]  Starting log with log level 4
[Sun Aug 17 17:10:39 2008] [info]  [Axis2] Axis2 worker created
[Sun Aug 17 17:10:39 2008] [debug] ..\..\src\core\engine\phase.c(121) 
axis2_handler_t *request_uri_based_dispatcher added to the index 0 of 
the phase Transport
[Sun Aug 17 17:10:39 2008] [debug] ..\..\src\core\engine\phase.c(121) 
axis2_handler_t *addressing_based_dispatcher added to the index 1 of the 
phase Transport
[Sun Aug 17 17:10:39 2008] [debug] ..\..\src\core\engine\phase.c(121) 
axis2_handler_t *rest_dispatcher added to the index 0 of the phase Dispatch
[Sun Aug 17 17:10:39 2008] [debug] ..\..\src\core\engine\phase.c(121) 
axis2_handler_t *soap_message_body_based_dispatcher added to the index 1 
of the phase Dispatch
[Sun Aug 17 17:10:39 2008] [debug] ..\..\src\core\engine\phase.c(121) 
axis2_handler_t *soap_action_based_dispatcher added to the index 2 of 
the phase Dispatch
[Sun Aug 17 17:10:39 2008] [debug] ..\..\src\core\engine\phase.c(121) 
axis2_handler_t *dispatch_post_conditions_evaluator added to the index 0 
of the phase PostDispatch
[Sun Aug 17 17:10:39 2008] [debug] ..\..\src\core\engine\phase.c(121) 
axis2_handler_t *context_handler added to the index 1 of the phase 
PostDispatch
[Sun Aug 17 17:10:39 2008] [debug] 
..\..\src\core\deployment\conf_builder.c(233) No custom dispatching 
order found. Continue with the default dispatching order
[Sun Aug 17 17:10:39 2008] [debug] 
..\..\src\core\deployment\conf_builder.c(378) Module addressing found in 
axis2.xml
[Sun Aug 17 17:10:39 2008] [debug] ..\..\util\src\class_loader.c(141) 
Object loaded successfully
[Sun Aug 17 17:10:39 2008] [debug] ..\..\util\src\class_loader.c(141) 
Object loaded successfully
[Sun Aug 17 17:10:39 2008] [debug] 
..\..\src\core\deployment\dep_engine.c(1306) 
axis2_dep_engine_load_module_dll: DLL path is : 
D:/axis2c/axis2c-bin-1.5.0-win32/modules/addressing/axis2_mod_addr.dll
[Sun Aug 17 17:10:39 2008] [error] ..\..\util\src\class_loader.c(161) 
dlerror reason: Something went wrong loading the DLL. If you happen to 
see this message, please note that getting the exact error form Windows 
is a TODO. And if possible please help fix it. :)
[Sun Aug 17 17:10:39 2008] [error] 
..\..\src\core\deployment\dep_engine.c(1424) Loading module description 
addressing failed
[Sun Aug 17 17:10:39 2008] [error] 
..\..\src\core\deployment\dep_engine.c(1588) Adding new module 
addressing to the deployment engine failed
[Sun Aug 17 17:10:39 2008] [error] 
..\..\src\core\deployment\repos_listener.c(136) Repository listener 
initialization failed
[Sun Aug 17 17:10:39 2008] [error] 
..\..\src\core\deployment\dep_engine.c(788) dep_engine repos listener 
creation failed, folder name is D:/axis2c/axis2c-bin-1.5.0-win32
[Sun Aug 17 17:10:39 2008] [error] 
..\..\src\core\deployment\conf_init.c(64) Loading deployment engine 
failed for repository D:/axis2c/axis2c-bin-1.5.0-win32.

Any suggestion?
Thank you,
Laci

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message