axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martina08 <martin.willitz...@gmx.de>
Subject Re: compiling with gcc
Date Thu, 21 Aug 2008 07:31:21 GMT

hey Rajika yes this command i have already tried, but it doesnt find the
libraries!!!!Regardless of which library of
-laxutil
-laxis2_http_sender
-laxis2_http_receiver
.....ans so on

errror message is:
/usr/lib64/gcc/x86_64-suse-linux/4.2.1/../../../../x86_64-suse-linux/bin/ld:
skipping incompatible
/home/lxuser/Axis2CNew/axis2c-bin-1.5.0-linux/lib/libaxis2_http_sender.so
when searching for -laxis2_http_sender
/usr/lib64/gcc/x86_64-suse-linux/4.2.1/../../../../x86_64-suse-linux/bin/ld:
cannot find -laxis2_http_sender
collecct2: ld returned 1 exit status
I dont know what is the reason for this problem, have somebody had the same
problems? 
Meantime I despair of this error :(



jakh wrote:
> 
> On Wed, Aug 20, 2008 at 7:09 PM, Martina08 <martin.willitzkat@gmx.de>
> wrote:
> gcc -o mathexecute -I$AXIS2C_HOME/include/axis2-1.5.0/ -L$AXIS2C_HOME/lib
> -laxis2_http_sender -laxis2_http_receiver *.c  -Wl,--rpath
> -Wl,$AXIS2C_HOME/lib
> 
> -Rajika
> 
> 
>> Hi,
>> anyway i have problems to link Libraries i think. I dont know how to
>> compile
>> und link the math Example.
>> I change the command to:
>> gcc -o mathexecute -I$AXIS2C_HOME/include/axis2-1.5.0/ -L$AXIS2C_HOME/lib
>> -laxutil -laxis2_axiom -laxis2_parser -laxis2_engine -lpthread
>> -laxis2_http_sender -laxis2_http_receiver math_client.c axis2_math_stub.c
>> axis2_math_stub.h -ldl -Wl,--rpath -Wl,$AXIS2C_HOME/lib
>> but there are still the undefined reference errors:( Can somebody give me
>> a
>> right gcc command to compile and link the math-example with generated
>> stubs?
>>
>>
>>
>> Martina08 wrote:
>> >
>> > ok i try it. In the manual the example includes only the hello.c file,
>> > there is no additional header file for this example, that why it
>> suffices
>> > only compile and link the hello.c File. So i hope i solve my problem
>> > otherwise i report my new problem again ;) Thanks for the fast help!!
>> >
>> >
>> >
>> > jakh wrote:
>> >>
>> >> On Wed, Aug 20, 2008 at 5:22 PM, Martina08 <martin.willitzkat@gmx.de>
>> >> wrote:
>> >>
>> >>>
>> >>> hi,
>> >>> yes i have set my $AXIS2C_HOME variable. I go over the manuals from
>> >>> where i
>> >>> have the gcc-command.
>> >>> But i tried to compile the math example and not the hello example. I
>> go
>> >>> to
>> >>> folder $AXIS2C_HOME/samples/client/math.  There are the 3 Files,
>> which
>> i
>> >>> want to compile and link. The files are:
>> >>> axis2_math_stub.c
>> >>> axis2_math_stub.h
>> >>> math_client.c
>> >>> Must i include the stub files (.c and .h) into the command?
>> >>
>> >>
>> >> Yes you do, seems like you have missed what is at the end of the
>> command
>> >> from the manual.
>> >>
>> >> -Rajika
>> >>
>> >>
>> >>> I want to have
>> >>> an executable File, which i can then use with the axis2 server...
>> >>>
>> >>> thanks for the answers...
>> >>> salute
>> >>>
>> >>>
>> >>>
>> >>> Martina08 wrote:
>> >>> >
>> >>> > I want to build the math-example. My command is like the manual:
>> >>> > gcc -o mathexecute -I$AXIS2C_HOME/include/axis2-1.5.0/
>> >>> -L$AXIS2C_HOME/lib
>> >>> > -laxutil -laxis2_axiom -laxis2_parser -laxis2_engine -lpthread
>> >>> > -laxis2_http_sender -laxis2_http_receiver math_client.c ldl
>> >>> -Wl,--rpath
>> >>> > -Wl,$AXIS2C_HOME/lib
>> >>> >
>> >>> > There is the error "Cannot find -laxutil ". I know the Libraries
>> exist
>> >>> and
>> >>> > I set the $AXIS2C_HOME/lib to the LD_LIBRARY_PATH but this dont
>> solve
>> >>> the
>> >>> > problem. In which folder I must execute this command?
>> >>> > Have i forget something?
>> >>> > When i use the complete Path to the libs like:
>> >>> > gcc -o mathexecute -I$AXIS2C_HOME/include/axis2-1.5.0/
>> >>> -L$AXIS2C_HOME/lib
>> >>> > -L$AXIS2C_HOME/lib/libaxutil.so
>> -L$AXIS2C_HOME/lib/libaxis2_axiom.so
>> >>> > ...........
>> >>> > then the compiler find the libraries(there is no error) but then
i
>> get
>> >>> > much more "undefined reference to"-errors in function main like:
>> >>> > undefined reference to axutil_env_create_all
>> >>> > undefined reference to axutil_strcmp
>> >>> > .
>> >>> > .
>> >>> > .
>> >>> > Does somebody know where is my mistake?
>> >>> >
>> >>>
>> >>> --
>> >>> View this message in context:
>> >>> http://www.nabble.com/compiling-with-gcc-tp19066875p19067851.html
>> >>> Sent from the Axis - C++ - User mailing list archive at Nabble.com.
>> >>>
>> >>>
>> >>> ---------------------------------------------------------------------
>> >>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>> >>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>> >>>
>> >>>
>> >>
>> >>
>> >> --
>> >> http://wso2.org/
>> >> http://llvm.org/
>> >> http://osdev.org/
>> >>
>> >>
>> >
>> >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/compiling-with-gcc-tp19066875p19069660.html
>> Sent from the Axis - C++ - User mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>
>>
> 
> 
> -- 
> http://wso2.org/
> http://llvm.org/
> http://osdev.org/
> 
> 

-- 
View this message in context: http://www.nabble.com/compiling-with-gcc-tp19066875p19083843.html
Sent from the Axis - C++ - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message