axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martina08 <martin.willitz...@gmx.de>
Subject Axis c++ calculator compiling error, Admin Client
Date Fri, 15 Aug 2008 13:50:06 GMT

Hi all,
i have some problems with the Axis c++ calculator-example. I build my Client
with
g++ c.cpp -I$AXISCPP_HOME/include -I$AXISCPP_HOME/lib -ldl -laxiscpp_client
-o calculator  and
i get the error: "cannot find laxiscpp_client". I search in the mailing list
for this problem and change my command to:
g++ c.cpp -I$AXISCPP_HOME/include -I$AXISCPP_HOME/lib -ldl
-L<PathToTheLibrary>laxis_client.so -o calculator
Now i think it finds the library but i get the error "undefined reference to
'Calculator::Calculator()' "
I have search in the mailing list but all tipps don´t solve this problem.
I use Open Suse 10.3,compiler version 4.2.1 and try it with KDE/KDevelop
too, but it produces the same error.
I think i have set the LD_LIBRARY_PATH correctly. Maybe there is a conflict
with 32 and 64 bit processor.
Can anybody help me please?
After i can´t solve this problem i go on with the server guide. I run the
simle Axis Server with:
./simple_axis_server 8080 and then deploy the service with:
java org.apache.axis.client.AdminClient
-Lhttp://localhost:8080/axis/Services/AdminService deploy.wsdd
I get the message: "Porcessing file deploy.wsdd" 
Was the deploying successful or not? 
By checking the deploying configuration in the user server guide:Open a
browser and enter the link http://localhost/axis
I can´t open the link. Why it doesn´t work??
I hope there is somebody who can help me in some questions...
-- 
View this message in context: http://www.nabble.com/Axis-c%2B%2B-calculator-compiling-error%2C-Admin-Client-tp18998976p18998976.html
Sent from the Axis - C++ - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message