axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Karseras" <akarse...@gmail.com>
Subject Re: Service Client sending message multiple times to server
Date Thu, 10 Jul 2008 21:07:46 GMT
Hi,

I'll create the JIRA.

Concerning eclipse, I'll gladly commit anything back to the community - what
exactly would you require ?


Andy

On Thu, Jul 10, 2008 at 7:57 AM, Supun Kamburugamuva <supun06@gmail.com>
wrote:

> Hi Andy,
>
> I'm not sure how HTTPS stuff work. But please create a Jira so we won't
> forget the issue.
>
> From your mails it seems that you are using an eclipse project for Axis2/C.
> We really appreciate if you can commit it back to the community as there
> were few user requests regarding this.
>
> Regards,
> Supun..
>
>
> On Wed, Jul 9, 2008 at 11:49 PM, Andy Karseras <akarseras@gmail.com>
> wrote:
>
>> Many thanks.
>>
>> So I was using the axis2_options_set_http_auth_info call (as suggested in
>> Axis2/C Manual 16.2)  and had the following commented out in the axis2.ml...
>>
>> <parameter name="HTTP-Authentication" username="application"
>> password="wlyVdZZ05D8" locked="true"/>
>>
>> When using the method call, 2 messages are sent to the server.
>>
>> When using the axis2.xml with HTTP Authentication set, only one message is
>> sent (as expected).
>>
>> Are there any known problems with this method call that would prevent it
>> from operating in the same manner as the config settings in the axis2.xml ?
>>
>>
>> If one is not known, should I raise a JIRA ?
>>
>>
>> Andy
>>
>>
>>
>>
>>
>> On Wed, Jul 9, 2008 at 12:59 PM, Manjula Peiris <manjula@wso2.com> wrote:
>>
>>>
>>> On Wed, 2008-07-09 at 11:56 -0400, Andy Karseras wrote:
>>> > Having stepped through the code, I see the calls to send the message
>>> > twice being executed.
>>> >
>>> > In http_sender_c, the two calls to axis2_http_client_send are made at
>>> > lines 988 and 1054.
>>>
>>> This is because you should have specified http authentication in your
>>> axis2.xml
>>>
>>> -Manjula.
>>>
>>>
>>> >
>>> >
>>> >
>>> > Andy
>>> >
>>> > On Wed, Jul 9, 2008 at 10:43 AM, Andy Karseras <akarseras@gmail.com>
>>> > wrote:
>>> >         Thanks for the suggestion.
>>> >
>>> >         Using the tcpmon tool, I can definitely see 2 messages being
>>> >         sent to the server with one call to
>>> >         axis2_svc_client_send_receive().
>>> >         Uisng Eclipse, I have stepped in debug mode to prove this.
>>> >
>>> >         Samisa - would you have any ideas or suggestions why this is
>>> >         happening.
>>> >
>>> >         Could it be the HTTP client ?
>>> >
>>> >         Is there any further debugging I can enable to pinpoint in the
>>> >         code where the duplicate messages are being sent ?
>>> >
>>> >
>>> >         Andy
>>> >
>>> >
>>> >
>>> >         On Wed, Jul 9, 2008 at 3:59 AM, Supun Kamburugamuva
>>> >         <supun06@gmail.com> wrote:
>>> >                 Hi,
>>> >
>>> >                         If there is anything I can set to show whether
>>> >                         duplicate messages are being sent, please let
>>> >                         me know.
>>> >
>>> >
>>> >                 You can use the TCPmon tool.
>>> >                 http://ws.apache.org/commons/tcpmon/.
>>> >
>>> >                 Supun..
>>> >
>>> >
>>> >
>>> >
>>> >
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>
>>>
>>
>

Mime
View raw message