axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dimuthu Gamage" <dimut...@gmail.com>
Subject Re: SOAP fault not working with axis2c latest revision(663886) from code generated from axis2/java using adb
Date Fri, 06 Jun 2008 15:57:25 GMT
Hi,
The idea case should be the server responding with a fault. I think issue
for another JIRA. :(

Thanks
Dimuthu
On Fri, Jun 6, 2008 at 4:25 PM, naveen bhat <naveenbhat04@googlemail.com>
wrote:

> Hello group,
>
> I used axis2/java 1.4 to generate server side code from wsdl.
> I did not write the business logic in the service skeleton(i.e all empty
> operations returning NULL).
> I compiled the code to generate libMyService.so.
> I deployed the service(libMyService.so and services.xml).
> I made a request from the axis2/java client.
> Ideally client should receive a soap fault from server.
> But server is not sending any response.
> I monitored the soap messages using tcpmon and found that the server is
> sending only http header, and there was no soap message in response.
> I also experimented the same steps using axis2/java nightly build(available
> at http://people.apache.org/dist/axis2/nightly) but the result remained
> the same.
>
> Need help in this regard.Let me know if you need more details
>
> *PS*: command used to generate the server side code
> WSDL2C.sh -uri <wsdl path> -ss -sd -d adb -u.
> *Environment*:
> axis2c revision number 663886.
> axis2/java 1.4 and also axis2/java nighlty build
>
> Thanks in advance
> Navin Bhat
>

Mime
View raw message