axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vamsi krishna <vamsibt...@yahoo.com>
Subject Re: Clarification needed
Date Fri, 06 Jun 2008 08:44:12 GMT
Hi Dinesh,
                I dont have any issues with axis2.xml which is getting loaded as this acts
as a config file for the axis engine. 
                But why are the service.xml of each and every service getting loaded at client
side? 
   
  Thanks & Regards,
  Vamsi Krishna M

Dinesh Premalal <xydinesh@gmail.com> wrote:
  Hi Vamsi,

vamsi krishna writes:

> Hi All,
> 1. I observed that the service xmls are getting loaded at both server
> side and client side. may i know the reason for loading the services at the
> client side? I believe the service xmls are related to server and
> not client.

I think you missed a point here. Because only xml that use in server
side and client side is axis2.xml which carries the all configuration
information for axis2 engine. AFAIK, in client side no service.xml
using.

> 2. Should we have the whole axis2C package on the client side inorder
> to consume any web service? wont the WSDL2C.sh generated code not suffice to
> consume the service?

Yes, we need to have Axis2/C engine installed. WSDL2C.sh generated
code use Axis2/C engine inorder to consume webservice.

thanks,
Dinesh

-- 
http://nethu.org

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org




Vamsi, IIIT-Hyd.


       
Mime
View raw message