axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dimuthu Gamage" <dimut...@gmail.com>
Subject Re: [Axis2] Server did not recognize the value of HTTP Header SOAPAction
Date Mon, 12 May 2008 16:55:40 GMT
Did you set the soap action correctly, i mean using the
"axis2_options_set_soap_action" function?, or can you capture the
request message using a tool like tcpmon and check the soap action is
correctly set or not?

Thanks
Dimuthu

On Mon, May 12, 2008 at 10:11 PM, Fan, Jan-fon <jan-fon.fan@intel.com> wrote:
>
>
> Hi,
> I am trying to use Axis2C client API from Linux to consume a web services
> that is created by Microsoft .NET in Windows.
> But the return of axis2_svc_client_send_receive function indicates:
>
> <soap:Fault xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
> <faultcode>soap:Client</faultcode>
> <faultstring>System.Web.Services.Protocols.SoapException:
> Server did not recognize the value of HTTP Header SOAPAction: .
>      at
>  System.Web.Services.Protocols.Soap11ServerProtocolHelper.RouteRequest()
>      at System.Web.Services.Protocols.SoapServerProtocol.Initialize()
>      at System.Web.Services.Protocols.ServerProtocolFactory.Create(Type
>  type, HttpContext context, HttpRequest request, HttpResponse response,
>  Boolean&amp; abortProcessing)</faultstring>
> <detail/>
> </soap:Fault>
>
>
> It seems to me that there is something wrong in the SOAPAction, what
> might be the reason causing this problem.
>
> Thanks,
> Jan-fon
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message