axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fan, Jan-fon" <jan-fon....@intel.com>
Subject Soap request to Microsoft .NET web services
Date Thu, 15 May 2008 18:13:26 GMT
Hi,

I created a simple "hello world" web services by using Microsoft .NET.
User specifies the first name and last name, this service just returns
"Hello World first_name last_name" to the user.

The soap request defined for this web services is:

 

<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">

  <soap:Body>

    <HelloWorld
xmlns="http://scxpd9984.amr.corp.intel.com/webservices/">

      <first_name>string</first_name>

      <last_name>string</last_name>

    </HelloWorld>

  </soap:Body>

</soap:Envelope>

 

 

I use Axis2C client API trying to consume this web services, but the
service just returns me "Hello World", the name part is missing.

I use a sniffer program to check what is the request that I send to
server and find out it is:

 

<soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">

  <soapenv:Header></soapenv:Header>

    <soapenv:Body>

    <HelloWorld>

      <first_name>Jan-fon</first_name>

      <last_name>Fan</last_name>

    </HelloWorld>

  </soapenv:Body>

</soapenv:Envelope>

 

 

 

I am wonder if this problem is caused by the name space <HelloWorld>, it
does not contain xmlns=http://scxpd9984.amr.corp.intel.com/webservices/.

Another thing is that the starting tag, they are different: soap vs
soapenv.

 

Can someone help me please.

 

Thanks,

Jan-fon


Mime
View raw message