axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dinesh Premalal <xydin...@gmail.com>
Subject Re: axis2c-1.4 can not retrieve SOAP 1.2 FAULT element
Date Thu, 22 May 2008 05:56:48 GMT
Hi Donald,
"donald yang" <donaldyy@googlemail.com> writes:

> Hi, I wrote a web service client using axis2c-1.4 to invoke a web service
> written using axis2-java. In this test case, the web service will return a SOAP
> fault element back to the web service client. If the soap version is set to
> 1.1, the web service client can retrieve the info from the SOPA FAULT element.
> However  the web service can NOT retrieve the info from the SOAP FAULT element
> if the soap version is set to 1.2. I have traced down and found that
> axis2_msg_ctx_get_soap_envelope(res_msg_ctx, env) statement in
> axis2_svc_client_send_receive_with_op_qname function of svc_client.c should
> return a pointer to soap_envelop, but it returns NULL. That is why the web
> service client can not retrieve the SOAP FAULT element. I have used TCP monitor
> to see the SOAP messages. There is a SOAP reply message return from server
> side.(see [1], [2]).
>
> Does anyone know how to solve this issue? many thanks in advance.
I don't think we had such a problem earlier. Could you please raise a
jira ?

thanks,
Dinesh
-- 
http://nethu.org

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message