axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Bolgarov" <a...@bolgarov.org>
Subject Axic2C 1.4.0: "NULL parameter was passed..." in Apache log
Date Wed, 07 May 2008 16:46:03 GMT
Hi,

I have just downloaded and build the latest Axis2C v. 1.4.0, and
deployed the mod_axis2.so into the Apache httpd web server.

Then I run the 'echo' sample (that is, I build the echo client and
service samples, deployed the service within the httpd environmet and
run the client), everything looks OK so far but in the httpd log I see
following lines (one line per the request: when I run 1000 iterations
of the echo client, I see 1000 such lines in the apache error log):

    [Wed May  7 11:22:32 2008] [error] string.c(47) NULL parameter was
passed when a non NULL parameter was expected

Looks like this error message originates from the
axutil_string_create() function (file util/src/string.c, line 47), but
I'm not sure from where the axutil_string_create() function is being
called.

When I run the echo service within axis2_http_server environment (not
from the Apache httpd with mod_axis2), there is no such errors in the
[repository]/logs/echo.log file, so this might be related to the
mod_axis2 implementation.

The client receives the correct response, so the error must not be fatal.

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message