axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaushalye Kapuruge <kausha...@wso2.com>
Subject Re: [Axis2] Server did not recognize the value of HTTP Header SOAPAction
Date Mon, 12 May 2008 22:15:24 GMT
Fan, Jan-fon wrote:
> Hi Dimuthu,
> Thank you so much.
> I tried to use tcpdump to see what is the soap message when I send out
> my request, but I find out that I don't have the permission to run
> tcpdump.
> However, after I try to use axis2_options_set_soap_action function
> according to your suggestion, the server can recognize the action now.
> But I have another problem, from the server's return, the payload does
> not contain the required parameters.
>   
Is it a SOAP fault or an empty response? What's expected result and what 
is you are getting now?
Cheers,
Kau
> This is what I set up my payload:
>
>
> axiom_node_t *GetData_om_node = NULL;
> axiom_element_t *GetData_om_ele = NULL;
> axiom_node_t *text_om_node = NULL;
> axiom_element_t *text_om_ele = NULL;
>
>
> ns1 = axiom_namespace_create(env, "http://test.intel.com", "nsl");
>
> GetData_om_ele = axiom_element_create(env, NULL, "GetData", ns1,
> &GetData_om_node);
>
> text_om_ele = axiom_element_create(env, GetData_om_node, "LotNumber",
> NULL, &text_om_node);
>
> axiom_element_set_text(text_om_ele, env, "149544", text_om_node);
>
> GetData_om_node is the payload that I use for
> axis2_svc_client_send_receive function.
>
>
> What part did I miss?
>
>
> Jan-fon
>
>
>
> -----Original Message-----
> From: Dimuthu Gamage [mailto:dimuthuc@gmail.com] 
> Sent: Monday, May 12, 2008 9:56 AM
> To: Apache AXIS C User List
> Subject: Re: [Axis2] Server did not recognize the value of HTTP Header
> SOAPAction
>
> Did you set the soap action correctly, i mean using the
> "axis2_options_set_soap_action" function?, or can you capture the
> request message using a tool like tcpmon and check the soap action is
> correctly set or not?
>
> Thanks
> Dimuthu
>
> On Mon, May 12, 2008 at 10:11 PM, Fan, Jan-fon <jan-fon.fan@intel.com>
> wrote:
>   
>> Hi,
>> I am trying to use Axis2C client API from Linux to consume a web
>>     
> services
>   
>> that is created by Microsoft .NET in Windows.
>> But the return of axis2_svc_client_send_receive function indicates:
>>
>> <soap:Fault xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
>> <faultcode>soap:Client</faultcode>
>> <faultstring>System.Web.Services.Protocols.SoapException:
>> Server did not recognize the value of HTTP Header SOAPAction: .
>>      at
>>
>>     
> System.Web.Services.Protocols.Soap11ServerProtocolHelper.RouteRequest()
>   
>>      at System.Web.Services.Protocols.SoapServerProtocol.Initialize()
>>      at
>>     
> System.Web.Services.Protocols.ServerProtocolFactory.Create(Type
>   
>>  type, HttpContext context, HttpRequest request, HttpResponse
>>     
> response,
>   
>>  Boolean&amp; abortProcessing)</faultstring>
>> <detail/>
>> </soap:Fault>
>>
>>
>> It seems to me that there is something wrong in the SOAPAction, what
>> might be the reason causing this problem.
>>
>> Thanks,
>> Jan-fon
>>
>>
>>
>>
>>     
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>
>   


-- 
http://blog.kaushalye.org/
http://wso2.org/


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message