axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaushalye Kapuruge <kausha...@wso2.com>
Subject Re: axis2_http_server fails on solaris9
Date Tue, 08 Apr 2008 17:08:09 GMT
OK. I checked the code and found that even a failure in a module can 
also result in such an error. So can you do the same for the modules 
directory too? Note that you need to remove the relavent entry <engage 
...> in the axis2.xml file as well.
Am not sure the debug message directly relates to the problem we have 
here. But can you attach your axis2.xml file to have a look?
Meantime appreciate if someone can enlighten Manfred, if this is a 
Solaris issue...
-Kau

Manfred Bohlmann wrote:
> Hi Kaushalye,
>
> if the services directory contains one or more or all of the subdirectories: the result
is the same. The log file reports 
>
> [error] dep_engine.c(768) dep_engine repos listener creation failed, folder name is ../
> [error] conf_init.c(67) dep engine load failed. conf value is NULL
> [error] http_server_main.c(217) Server creation failed: Error code: 34 :: Repository
listener initialization failed
>
> Before these messages there is another one, that might perhaps be interesting (not related
to presence or absence of services subfolders):
>
> [debug] conf_builder.c(233) no custom dispatching order found continue with default dispatching
order
>
>
> Manfred
>
>   
>> -----Ursprüngliche Nachricht-----
>> Von: "Apache AXIS C User List" <axis-c-user@ws.apache.org>
>> Gesendet: 08.04.08 17:47:05
>> An: Apache AXIS C User List <axis-c-user@ws.apache.org>
>> Betreff: Re: axis2_http_server fails on solaris9
>>     
>
>
>   
>> Hi,
>> Instead of removing the service directory, can you move sub 
>> directories(services lice echo and math) to another place one by one and 
>> try to start the server? The idea is to check which service has the fault.
>> Cheers,
>> Kaushalye
>>
>> Manfred Bohlmann wrote:
>>     
>>> Hi Dinesh, hi Supun again,
>>>
>>> I cannot discover any errors with the .so files in services/*. If I remove the
services directory, the log file reports
>>>
>>> [error] dir_handler.c(220) No files in the path ..//services. 
>>>
>>> and the final message is 
>>>
>>> [error] http_server_main.c(217) Server creation failed: Error code: 34 :: Repository
listener initialization failed
>>>
>>> again.
>>>
>>>
>>> Manfred
>>>
>>>   
>>>       
>>>> -----Ursprüngliche Nachricht-----
>>>> Von: "Apache AXIS C User List" <axis-c-user@ws.apache.org>
>>>> Gesendet: 08.04.08 15:36:03
>>>> An: "Apache AXIS C User List" <axis-c-user@ws.apache.org>
>>>> Betreff: Re: axis2_http_server fails on solaris9
>>>>     
>>>>         
>>> Hi,
>>>   
>>>       
>>>>
>>>> Also dep_engine fails if the service folder is not present.
>>>>
>>>> Also, it fails if the service so files are corrupted and cannot be loaded.
>>>>
>>>>
>>>> In this case you can , remove all services in services directory and check
whether server starts ?
>>>>
>>>> thanks,
>>>> Dinesh 
>>>>
>>>>
>>>>
>>>> -- 
>>>> http://nethu.org/
>>>>
>>>>     
>>>>         
>>> ...
>>>       
>> -- 
>> http://blog.kaushalye.org/
>> http://wso2.org/
>>
>>     
> _________________________________________________________________________
> Mit der Gruppen-SMS von WEB.DE FreeMail können Sie eine SMS an alle 
> Freunde gleichzeitig schicken: http://freemail.web.de/features/?mc=021179
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>
>   


-- 
http://blog.kaushalye.org/
http://wso2.org/


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message