axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <sam...@wso2.com>
Subject Re: Yet another cannot load mod_axis2.dll problem
Date Tue, 08 Apr 2008 13:30:04 GMT
Andre Coelho wrote:
> Why you guys never answers my threads? It's the third one without answers.

The number of developers currenly maintaining Axis C++ has dropped in 
number and less active. This is partially because more developers are 
into Axis2/C. To be frank, I did not have a chance to look into Axis C++ 
for a long time.

Anyway, looking at the problem you have, looks like httpd cannot locate 
the module file. So do the following:
1. Check if mod_axis2.dll is in C:/Program Files/Apache 
Group/Apache2/modules/
2. If it is already there, make sure you have added dependent dlls, such 
as Xerces dll to the path

Also, make sure that, once the path is set, you have to start a new 
command line to make the changes take effect before stating httpd.

BTW, if you are just starting up, why not use Axis2/C?

Thanks,
Samisa...

>
> Please, help me. I'm new to axis!
>
> On Thu, Apr 3, 2008 at 4:47 PM, Andre Coelho <andre.durst@gmail.com 
> <mailto:andre.durst@gmail.com>> wrote:
>
>     By the way, I'm using the binaries.
>
>     On Thu, Apr 3, 2008 at 4:20 PM, Andre Coelho
>     <andre.durst@gmail.com <mailto:andre.durst@gmail.com>> wrote:
>
>         So, I'm using apache 2.0.63, Xerces 2.2.0 and Axis c++ 1.6b.
>
>         My httpd looks like this on the end:
>
>         LoadModule axis_module modules/mod_axis2.dll
>         <Location /axis>
>         SetHandler axis
>         </Location>
>
>
>         And the conf like this:
>         LogPath:C:\Program Files\Apache
>         Group\Apache2\Axis\logs\AxisLog.txt
>         WSDDFilePath:C:\Program Files\Apache
>         Group\Apache2\Axis\conf\server.wsdd
>         XMLParser:C:\Program Files\Apache
>         Group\Apache2\Axis\lib\AxisXMLParser.dll
>         Transport_http:C:\Program Files\Apache
>         Group\Apache2\Axis\lib\HTTPTransport.dll
>         Channel_HTTP:C:\Program Files\Apache
>         Group\Apache2\Axis\lib\HTTPChannel.dll
>         Channel_HTTP_SSL:C:\Program Files\Apache
>         Group\Apache2\Axis\lib\HTTPSSLChannel.dll
>
>
>         I'm sure all DLLs are on those file paths
>
>         But i still get this when trying to initialize:
>
>         Syntax error on line 957 of C:/Program Files/Apache
>         Group/Apache2/conf/httpd.conf:
>         Cannot load C:/Program Files/Apache
>         Group/Apache2/modules/mod_axis2.dll into server: The specified
>         module could not be found.
>
>
>         I know that's an old problem, but i haven't found any helpful
>         answers on the mailing list.
>
>         Any suggestions?
>         I'm counting on you guys...
>
>
>
> ------------------------------------------------------------------------
>
> No virus found in this incoming message.
> Checked by AVG. 
> Version: 7.5.519 / Virus Database: 269.22.6/1360 - Release Date: 4/4/2008 6:02 PM
>   


-- 
Samisa Abeysinghe 
Software Architect; WSO2 Inc.

http://www.wso2.com/ - "Oxygenating the Web Service Platform."


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message