axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mymail0345@orange.nl" <mymail0...@orange.nl>
Subject Re: MSVCR80
Date Sat, 05 Apr 2008 10:57:18 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
Hi Senaka,<br>
<br>
Running this newer version makes the MSVCR80 error go away, but now the
error "The system cannot execute the specified program." appears in the
console,&nbsp; not in a separate dialog box as before.<br>
<br>
Am I right that, given the axis2c.zip is unpacked, for running the
example there are 3 prerequisites:<br>
- setting the path correctlty sot that it points to the lib directory<br>
- setting the AXIS2C_HOME variable<br>
- copying some DLL files to the AXIS2C_HOME/lib directory (zlib1/dll,
iconv.dll, libxml2.dll)<br>
<br>
This appears in my dos box:<br>
&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;<br>
H:\axis2c-bin-1.3.0-win32\bin&gt;echo %path%<br>
H:\WINDOWS\system32;H:\WINDOWS;H:\WINDOWS\system32\wbem;h:\program
files\matlab\<br>
r2006bxp64\bin;H:\Program Files (x86)\MATLAB\R2008a\bin;H:\Program
Files (x86)\M<br>
ATLAB\R2008a\bin\win32;H:\Program Files
(x86)\MATLAB\R2006b\bin;H:\Program Files<br>
&nbsp;(x86)\MATLAB\R2006b\bin\win32;h:\program
files\matlab\r2006bxp64\bin\win64;H:\P<br>
rogram Files (x86)\MATLAB\MATLAB Component
Runtime\v75\runtime\win32;h:\axis2c-b<br>
in-1.3.0-win32\lib<br>
<br>
H:\axis2c-bin-1.3.0-win32\bin&gt;echo %AXIS2C_HOME%<br>
h:\axis2c-bin-1.3.0-win32<br>
<br>
H:\axis2c-bin-1.3.0-win32\bin&gt;axis2_http_server.exe<br>
The system cannot execute the specified program.<br>
&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;<br>
<br>
Kind regards,<br>
Nanne<br>
<br>
<br>
Senaka Fernando schreef:
<blockquote
 cite="mid:48778.124.43.203.54.1207390667.squirrel@webmail6.pair.com"
 type="cite">
  <pre wrap="">Hi Nanne,

Can you try the binary at [1]. This is newer than the one you find on the
release page, as it was built from the head after 1.3.0 was released.

[1] <a class="moz-txt-link-freetext" href="http://people.apache.org/~senaka/axis2/c/axis2c-bin-1.3.0-win32.zip">http://people.apache.org/~senaka/axis2/c/axis2c-bin-1.3.0-win32.zip</a>

Regards,
Senaka

  </pre>
  <blockquote type="cite">
    <pre wrap="">        Hi Supun, Senaka

 Given the suggestions of Supun, I have tried the following without
result:
 - removed the directory and  unzipped the contents of
axis2c-bin-1.3.0-win32.zip again.
 - removed the directory and tried a previous version
axis2c-bin-1.2.0-win32.zip
 - placed one of the copies of MSVCR80.dll found on my machine in the
windows/system32 directory (in this case a different error occurs)
 - read the post on
<a class="moz-txt-link-freetext" href="http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=15218&amp;SiteID=1">http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=15218&amp;amp;SiteID=1</a>.

 Given the suggestions of Senaka:
 - many problems with  MSVCR80.dll posted on the internet seem to have to
do with manifest files indeed. Some replies describe how problems can be
fixed , but I don't imagine that such specialized actions would be needed
to get the examples shipped with axis2c running. Anyway, my clients would
not be able to repeat these steps.
 - Initially I was working with Microsoft Visual C++ 6.0 (1994-1998)
 - Meanwhile I have installed express editions of Microsoft Visual C++ 9.0
(2008)  and Microsoft Visual C++ 2005
 - I have compiled a 1 line console application with Microsoft Visual C++
2005 which runs from the dos prompt
 - I work on a machine with xp64 SP2 installed, the problem reproduces on
a XP machine (although this machine had no Microsoft Visual 2005)

 After the above steps, the MSVCR80.dll error still appears when starting
"axis2_http_server.exe". If I try any of the exe files in the directory
"samples", the same error occurs.

 Kind regards,
 Nanne




 Senaka Fernando schreef:    Hi Supun, Nanne,  I can be that someone build
without embedding the manifest files, and then removed the manifest files
before packing. Or else it may be that you have an embedded or visible
manifest that needs a different version of MSVCR80.dll. Nanne, btw, what
is your VS version (don't you have VS at all?) and what is your win32
version (WinXP/Vista version)?  We have not run into this issue with the
Axis2/C 1.3.0 binary. But, in my case I had Windows XP SP2, and Visual
Studio 2005.  Regards, Senaka            Hi Nanne,  This occurs all the
time to me also. When this occurs I simply clean all the binaries and
build them again and the error vanishes. So I couldn't find a specific
reason for this error to occur. It seems that building the binaries is
not an option for you. So I suggest delete all the Axis2/C binaries and
start again.  Also this post might help.
<a class="moz-txt-link-freetext" href="http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=15218&amp;SiteID=1">http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=15218&amp;amp;SiteID=1</a>
Regards, Supun.  On Fri, Apr 4, 2008 at 12:02 PM, <a class="moz-txt-link-abbreviated" href="mailto:mymail0345@orange.nl">mymail0345@orange.nl</a>
wrote:                 Hello,   I am a newbe to axis2c. I would like to
run the example "axis2_http_server.exe" as a first step.   I have
downloaded the binary distribution and followed the steps on
<a class="moz-txt-link-freetext" href="http://ws.apache.org/axis2/c/docs/installationguide.html#win_binary">http://ws.apache.org/axis2/c/docs/installationguide.html#win_binary</a>
  In
step 2.1.3 (Running the binaries) I have set and verified AXIS2C_HOME and
the PATH variable and now try to run axis2_http_server.exe   Then an
error message "This application failed to start because MSVR80.dll was
not found" appears in a dialog box.   Simply copying this file to the
library path does  not really help because then a different error
appears.   I have repeated the procedure on a different PC with exactlty
identical results.   I searched the mailing list, and found some hits on
"MSVCR80" but was not able to resolve the problem.   Does anywone know
what to do?   Regard,  Nanne
---------------------------------------------------------------------  To
unsubscribe, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-unsubscribe@ws.apache.org">axis-c-user-unsubscribe@ws.apache.org</a>
 For
additional commands, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-help@ws.apache.org">axis-c-user-help@ws.apache.org</a>
    ---------------------------------------------------------------------
To unsubscribe, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-unsubscribe@ws.apache.org">axis-c-user-unsubscribe@ws.apache.org</a>
For
additional commands, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-help@ws.apache.org">axis-c-user-help@ws.apache.org</a>
--------------------------------------------------------------------- To
unsubscribe, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-unsubscribe@ws.apache.org">axis-c-user-unsubscribe@ws.apache.org</a>
For additional
commands, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-help@ws.apache.org">axis-c-user-help@ws.apache.org</a>
     ---------------------------------------------------------------------
To unsubscribe, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-unsubscribe@ws.apache.org">axis-c-user-unsubscribe@ws.apache.org</a>
For
additional commands, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-help@ws.apache.org">axis-c-user-help@ws.apache.org</a>
    </pre>
  </blockquote>
  <pre wrap=""><!---->

---------------------------------------------------------------------
To unsubscribe, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-unsubscribe@ws.apache.org">axis-c-user-unsubscribe@ws.apache.org</a>
For additional commands, e-mail: <a class="moz-txt-link-abbreviated" href="mailto:axis-c-user-help@ws.apache.org">axis-c-user-help@ws.apache.org</a>



  </pre>
</blockquote>
<br>
</body>
</html>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message