axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rahil Ali <rahil....@tpsonline.com>
Subject Re: Webserivce call through Axis fails..
Date Sun, 13 Apr 2008 05:31:14 GMT
Hi Dimuthu,
   
  Thanks for the replies and help. Couple of questions again ... What is the use of service.xml
when I am just a client. Secondly I saw the file you attached, pls explain how did u generated
such organised code, also pls explain the directory structure... I am trying on the nightly
build you mentioned earlier and will respond the results. 

Thanks & Regards,
  Rahil Ali

Dimuthu Gamage <dimuthuc@gmail.com> wrote:
  My early email was reported rejected by the recipient. This should be
due to the large attachment. I will keep the test case uploaded at
http://people.apache.org/~dimuthu/leisure/1_dec/case37_servicexml.zip

Thanks
Dimuthu

On Sat, Apr 12, 2008 at 12:25 PM, Dimuthu Gamage wrote:
> Hi Rahil,
>
> This should be due to the service.xml has '-', and '.' characters for
> the service name and the service class name. In the latest svn this
> issue is corrected. And I was able to fix the issue in missing 'adb_'
> prefix too, so you can use the original WSDL without doing any changes
> with.
>
> You may wait until the today's axis2/java nightly build, or just use
> the attached files.
>
> Thanks
> Dimuthu
>
>
>
> On Thu, Apr 10, 2008 at 4:26 PM, Samisa Abeysinghe wrote:
> > Rahil Ali wrote:
> >
> > > Yes, I am using code generated by WSDL2C using this command :
> > > "WSDL2C.sh -uri GSCP-service.serviceagent.wsdl -u -d adb"
> > > I am trying to call this operation: "SendSMSOp"
> > > Can you check whether my wsdl is ok or not. I have removed operations and
> > other non-related items from the original WSDL.
> > >
> >
> > The WSDL seems to be valid. If it was invalid, usually the codegen tools
> > trows an exception.
> >
> > Looking at the WSDL and the request sent by the client, the message sent is
> > not correct as far as I can tell. I am not sure if this is a bug in the
> > generated code or the user code.
> > We need a codegen expert to help us here :)
> >
> > Samisa...
> >
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-c-user-help@ws.apache.org
> >
> >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org





Mime
View raw message