axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sérgio Gomes" <sergiomdgo...@gmail.com>
Subject Header parameters being ignored
Date Wed, 26 Mar 2008 21:00:48 GMT
Hello again,

When sending my SOAP messages, I noticed that the headers were always
empty, even though the WSDL2C tool generated support for the header
fields:

adb_getAllAdWordsCampaignsResponse_t*
            axis2_stub_op_CampaignService_getAllAdWordsCampaigns(
axis2_stub_t *stub, const axutil_env_t *env,

adb_getAllAdWordsCampaigns_t* _getAllAdWordsCampaigns,

adb_useragent_t* _useragent22,

adb_password_t* _password23,
                                                        adb_email_t* _email24,

adb_clientEmail_t* _clientEmail25,

adb_clientCustomerId_t* _clientCustomerId26,

adb_developerToken_t* _developerToken27,

adb_applicationToken_t* _applicationToken28);

(There is also a bug that prevents the correct generation of the class
names, but it has already been confirmed and will be fixed, according
to the reply I received when I posted that issue)
(WSDL can be found at
https://adwords.google.com/api/adwords/v11/CampaignService?wsdl )

As you can see, the function header has all the items that should
appear on the SOAP header (useragent, password, etc), yet when I
analyzed the generated .c file, I noticed that these parameters were
being used nowhere, and thus the header would always be empty.

Any tips on this issue? Also, is there an alternate way to set the
outgoing SOAP header, so that I can work around the issue?


Thanks,
Sérgio

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message