axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Subra A Narayanan" <aswat...@gmail.com>
Subject Module conflict
Date Wed, 05 Mar 2008 21:17:48 GMT
Hello folks,

I am running in to another problem and was wondering if I could get some
help from you guys.

Another developer in my team had to add the following lines to httpd config
file. These lines are in a separate .conf file which is placed in the
/etc/httpd/conf.d/ directory and gets included in the main httpd.conf file.

DocumentRoot /srv/www/html/WebUI/public/
<Directory /srv/www/html/WebUI/public/>
Options ExecCGI FollowSymLinks
AddHandler cgi-script .cgi
AllowOverride all
Order allow,deny
Allow from all
</Directory>

We realized that once this is added, we are unable to access our axis2 soap
webservices. We are not even able to bring up the page that lists all the
services and the operations. Looks like that the axis2 httpd module isn't
loading properly.

I did some research and I think it might have something to do with the per
server config and per directory config structures in the axis2 apache
module. Do we have to merge the directory config structures? I am kind of
new to writing apache modules so pls excuse my ignorance if I am wrong. I
will continue to investigate this issue as one of my own apache module is
also not working because of this.

In the meantime, if you guys have any idea please let me know.


Thanks,
Subra

Mime
View raw message