axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rahil Ali" <rahil....@tpsonline.com>
Subject RE: Problem with Service deployed
Date Fri, 07 Mar 2008 06:57:53 GMT
Hello Senaka,

Thanks very much for your reply. I have some confusion, pls clarify it:
- I want to  deploy a web-service; I will follow these steps
	+ write a code and implement these functions (Service operation,
hello_init, hello_invoke, hello_on_fault, hello_free,
axis2_get_instance and axis2_remove_instance) and write a
service.xml
	+ I compiled that source and put it in the axis2c/service/Myservice
folder. (libMyservice.so, service.xml)
	+ Now I restart apache web server.(I have tried this with

	  "axis2_http_server" as well. And access this
URI("http://ip-address/asix2/services")
	
- After following these steps is my service ready to be used by any
.Net or other client?

- If yes then I am having some problems. Because the client cannot access
the .wsdl file for that service, and the browser only displays the service
name and available functions, no Hyper-links like the one showed in
AXIS/Java tutorial. Pls see the output of the browser from my previous
email.

- I believe that there must be some tool which will create the .wsdl for any
service that I write.

- Am I missing anything here.

Please help me get the clear picture of AXIS2/C web service deployment.

Thanks & Regards,
Rahil Ali
 

-----Original Message-----
From: Senaka Fernando [mailto:senaka@wso2.com] 
Sent: Thursday, March 06, 2008 10:29 PM
To: Apache AXIS C User List
Subject: Re: Problem with Service deployed

Hi Rahil,

We do have support for displaying static .wsdl files. But, the issue is we
don't simply publish the .wsdl file. For the moment, you can find the
required .wsdl file in the test/resources/wsdl/ folder.

I have started a discussion on the developer list regarding this concern,
[1]. Hope to have this issue fixed soon.

[1] http://marc.info/?l=axis-c-dev&m=120481700919297&w=2

Regards,
Senaka

> Hello everyone,
>
>
>
> I have configured AXIS2/C with apache2 web server. I compiled calculator
> sample with the following command:
>
> "gcc -shared -olibCalculator.o -I/usr/local/axis2c/include/axis2-1.3.0
> -L$AXIS2C_HOME/lib -laxutil -laxis2_axiom -laxis2_parser -laxis2_engine
> -lpthread -laxis2_http_sender -laxis2_http_receiver calc.c"
>
>
>
> Now when I access it through Internet explorer :
> http://192.168.4.163/axis2/services/Calculator it displays :
>
>
> Deployed Services
>
>
> Calculator
>
>
> This is a testing service, named 'Calculator' to test dynamic client
>
> Available Operations
>
> *	div
> *	add
> *	sub
> *	mul
>
> Problem is when I try to access its WSDL file by adding "?wsdl" at the end
> of URL it gives an error:
>
> The XML page cannot be displayed
>
> Cannot view XML input using style sheet. Please correct the error and then
> click the Refresh <javascript:location.reload()>  button, or try again
> later.
>
>   _____
>
> Invalid at the top level of the document. Error processing resource
> 'http://192.168.4.163/axis2/services/Calculator?wsdl'. ...
>
> Unable to retreive wsdl for this service
>
> ^
>
>
>
> When I tried to add this as a web-reference in VS.Net it displayed "The
> HTML
> document does not contain Web service discovery information.".
>
>
> Please help me where I am doing wrong.
>
>
>
> Regards,
>
> Rahil Ali
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message