axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gavan Hood <>
Subject Re: Axis "C" server support for dotnet client
Date Wed, 30 Jan 2008 12:07:27 GMT
I managed to get the path to the Service to be /axis2/services/TestData in the client. Even
though this is not a usable solution for production it did enable the server to locate the
service, it then generated another set of errors which I am looking at now...
  I still need to work out how to get the server to not require the prefix... but at least
I can find the service.. even if it wont run yet...

Gavan Hood <> wrote:
    Hi Dimuthu,
  I agree totallly, I have been working on that today, basically the dotnet client formats
the soap message so you cannot change that side. Which is understandable as a client should
not have to know knowlede of how the service is stored on the server. So I tried to configure
Axis2 to locate the / directory and locate the TestData folder under it. I could not find
a way to do that. Do you know of a way to do that?
  In summary: The axis server should not force the path to have /axis2/services prefix...
how do remove that ?

Dimuthu Gamage <> wrote:
  Hi Gavan,

If you recieve service not found error from axis2/c server, it can be
mostly due to the wrong endpoint.

If your service directory is "TestData" ( i.e. inside the axis2
services directory) your service endpoint should be

I can see in your fault you have set the endpoint to
"". Can you try with
"" as the service


On Jan 30, 2008 4:06 AM, Gavan Hood wrote:
> I renamed my previous post as the problem in my opinion is in the Axis2 C
> http server capabilities, which may be a design flaw. The server responds
> with a service not found error as it is unable to identify the correct
> The original post is below the tcpmon trace that follows. I am about to see
> what I can do to identify how the http server handles the http header and
> locates the service... the microsoft namespace QName looks different to what
> I see in the echo test.... which I appended to end of the message after the
> original text
> POST /TestData HTTP/1.1
> User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; MS Web Services Client
> Protocol 2
> .0.50727.1366)
> VsDebuggerCausalityData:
> uIDPo7iwHfJnmU1MsR+ixSBkQ/wAAAAAIcBQpWIKEkiCDjuzhhBtsBm
> dJpxYAh9KiKHDv3dFhhcACQAA
> Content-Type: text/xml; charset=utf-8
> SOAPAction: ""
> Host: localhost:9090
> Content-Length: 428
> Expect: 100-continue
> Connection: Keep-Alive
> > xmlns:soap="http://schemas.
> xmlns:xsi="
> " xmlns:xsd="">> xmlns="http:/
> /">localhostsampl
> esAerationfalse
> ◄
> /* retrieving time = 17:36:27*/
> /* time throughput = 0 sec(s)*/
> ---------------------
> HTTP/1.1 500 Internal Server Error
> Content-Type: text/xml;charset=UTF-8
> Connection: Keep-Alive
> Content-Length: 404
> > xmlns:soapenv="">> penv:Header/>soapenv:Server<
> faultstring>Service Not FoundService Not
> Found,
> Endpoint referance address is and wsa acti
> ons is
> (null)> ope>
> Gavan Hood wrote:
> I suspected a problem with MS support for WS basic profile as opposed to WS*
> indicated in Axis2C. I hoped there would be a solution but have not found
> anything. I am at a point where I need to tweak on of the two worlds... or
> drop Axis2. I still hope there is something I am missing that will let the
> following process work for me... Let me know your thoughts please.
> I have to generate a service that is equivalent to a asmx service that has
> dotnet clients, once I get that I can then extend...
> I know the MS and non MS worlds like to live in isolation, unfortunately I
> am in world that demands they work together.
> I started with a dotnet asmx web service.... generated its WSDL this was to
> be the base for the service environemnt.
> I then processed the WSDL with WSDL2C from Axis2 to give the C skeleton.
> I then compiled the skeleton (by modifying the echo sample makefile ...)
> With the dll etc in the Services folder, I can see it in the default 9090
> connection of listed services (which I think is just a dump of the xml
> folder contents).
> I autogenerated a C# client with MS visual studio from the WSDL. It worked
> fine with the .asmx file as you would expect.
> I then pointed it at the Axis2 server and watched the SOAP packets with
> tcpmon, I can see a significant difference in the format as expected.
> I now need to identify if there are:
> A settting for Microsoft tools to connect to the Axis2C server.
> A configuration setting to Axis2C server to handle dotnet clients as above
> If there is no simple change, is there a code change for the Axis2C server
> to trap these connections and translater them. I am guessing I either have
> to make a custom http handler or maybe there is a WS basic profile to WS*
> conversion utility that works like tcpmon....
> Any help much appreciated...
> ________________________________
> Never miss a thing. Make Yahoo your homepage.
> POST /axis2/services/echo HTTP/1.1
> User-Agent: Axis2/C
> Content-Length: 512
> Content-Type: application/soap+xml;charset=UTF-8
> Host: localhost:9090
> > xmlns:soapenv="">> nv:Header
> xmlns:wsa="">http://localh
> ost:9090/axis2/services/echo
> mples/echoString1b41e04d-25c6-45ba-8ced-88241f4a6160
> > xmlns:ns1="http:/
> /">Hello
> World!> soapenv:Body>å┘5\/☻
> /* retrieving time = 17:37:32*/
> /* time throughput = 0 sec(s)*/
> ---------------------
> HTTP/1.1 200 OK
> Content-Type: application/soap+xml;charset=UTF-8
> Content-Length: 672
> > xmlns:soapenv="">> nv:Header
> xmlns:wsa="">http://ws
> /localhost:9090/axis2/services/echo220f9
> b62-4535-4e35-9208-1c0043b6edb3> wsa:RelationshipTy
> pe="">1b41e04d-25c6-45ba-8ced-88241f4a
> 6160> xmlns:ns1="ht
> tp://">Hello
> World!> soapenv:Body>
> ________________________________
> Never miss a thing. Make Yahoo your homepage.

  Be a better friend, newshound, and know-it-all with Yahoo! Mobile. Try it now.

Looking for last minute shopping deals?  Find them fast with Yahoo! Search.
View raw message