axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trasca Virgil <virgil_tra...@yahoo.com>
Subject Re: Axis2C generated client issue (please see atached code for details)
Date Tue, 08 Jan 2008 19:05:12 GMT
Hi Dimuthu,

      I tried what you said but without success. Result is NULL again. But I tried also something
else. Please check the attached pictures. First picture is the list of services exposed, second
is a very simple service which I am able to call it also from C client , and third one should
returns some values from an XML config files but is returning NULL from c. Please see my atached
picture.

Thank you,
Virgil



----- Original Message ----
From: Trasca Virgil <virgil_trasca@yahoo.com>
To: Apache AXIS C User List <axis-c-user@ws.apache.org>
Sent: Tuesday, January 8, 2008 9:20:36 AM
Subject: Re: Axis2C generated client issue (please see atached code for details)


Hi,

    I will try that. BTW this is how I generated my c client code

<target name="generate.service.c.client"
 depends="generate.service.wsdl">
        <java classname="org.apache.axis2.wsdl.WSDL2C" fork="true">
                    <arg value="-uri"/>
                    <arg
 file="${resources.dir}/wsdl/BursterPublic.wsdl"/>
                    <arg value="-d"/>
                    <arg value="adb"/>
                    <arg value="-u"/>
                    <arg value="-o"/>
                    <arg value="${src.generated.dir}/axis2/c"/>
                    <classpath refid="axis2.classpath"/> 
                </java>

    </target>

Thank you,
Virgil

----- Original Message ----
From: Dimuthu Gamage <dimuthuc@gmail.com>
To: Apache AXIS C User List <axis-c-user@ws.apache.org>
Sent: Tuesday, January 8, 2008 8:45:46 AM
Subject: Re: Axis2C generated client issue (please see atached code for
 details)


Actually Payload can be null, in a case of an empty request (If the
WSDL says your request message is empty). There have been places where
users meet simmilar situations[1]. There the user could solved his
problem using the changed endpoint. That should be the solution for
this case as well.


[1]

 http://www.nabble.com/codegeneration-and-service-with-no-parameters-td14338901.html#a14374273

Thanks
Dimuthu

On Jan 8, 2008 11:57 AM, Trasca Virgil <virgil_trasca@yahoo.com> wrote:
> Hi,
>
>        Thank you for helping.
>        I attached also the wsdl file. Regarding compiling you can
 easily remove 1 wxWidgets stuff and it will compile. What I observed
 debugging and is strange is that generated line code
>
> ret_node =  axis2_svc_client_send_receive_with_op_qname(
>  svc_client, env, op_qname, payload);
>
> comes to execute with payload = NULL and I think this is incorrect.
 But this is generated code so because of that I don't know what to do.
>
> I am calling my webservice which is up from Settings.cpp.
>
> Thank you,
> Virgil
>
>
> ----- Original Message ----
> From: Dimuthu Gamage <dimuthuc@gmail.com>
> To: Apache AXIS C User List <axis-c-user@ws.apache.org>
> Sent: Tuesday, January 8, 2008 3:52:40 AM
> Subject: Re: Axis2C generated client issue (please see atached code
 for details)
>
>
> On Jan 8, 2008 7:18 AM, Dimuthu Gamage <dimuthuc@gmail.com> wrote:
> > Yea, It s better we have the WSDL file to figure out what has
> > happened.  I cant compile the code since I dont have installed
> > wxWidget. :(
> >
> > I assume this is a problem of dispatching the request with empty
>  body.
> > ( I noticed that your soap action is not the way Axis2 expected to
> > dispatch).
> >
> >
> > So can you try out setting the endpoint uri to.
> >
> >
 "http://your_actual_endpoint/axis2/services/BursterPublic/getStting"
>
> Correction: this should be
> "http://your_actual_endpoint/axis2/services/BursterPublic/getSetting"
> > (notice the end it is the operation name)
> >
> >
> > Thanks
> > Dimuthu
> >
> >
> >
> > On Jan 8, 2008 4:01 AM, Mark Nüßler <mark.nuessler@9elements.com>
>  wrote:
> > > Hello Trasca,
> > >
> > > [sry last mail i said Virgil not Trasca]
> > >
> > > can you please send the wsdl-file and the command
> > > you use to generate you code ?
> > >
> > > i think you have to you tcpmon, otherwise
> > > you wouldn't see what was transmitted - if
> > > something was really transmitted.
> > >
> > > mfg derMark
> > >
> > >
> > > Trasca Virgil schrieb:
> > >
> > > > Hi,
> > > >
> > > >     I am a newbie to Axis2C client and I have an issue. My
 server
>  is Axis2 Java 1.3 and is up with a service getSettings() which is
>  correct (I am 100% about that).
> > > >
> > > > The client is C and is generated with wsdl2c codegent. The
 issue
>  is than when I call getSettings from C I got NULL all the time even
 is
>  the service is working.
> > > > I tried to use tcpmon but with not success.
> > > >
> > > > in Settings.cpp
> > > > I have function getSettings() which is returning all the time
>  NULL even if I consider that I did all the pre-requites correctly.
 This
>  function should not return NULL but a corect value.
> > > >
> > > >
> > > > adb_getSettingsResponse_t* Settings::getSettings()
> > > > {
> > > >    return axis2_stub_BursterPublic_getSettings(stub,env);
> > > > }
> > > >
> > > >
> > > > What I observed by debugging and is strange is that in
 generated
>  code
> > > >
> > > > axis2_stub_BursterPublic_getSettings
> > > >
> > > > there is a call to
> > > >
> > > > ret_node =  axis2_svc_client_send_receive_with_op_qname(
>  svc_client, env, op_qname, payload); and here payload comes all the
 time NULL
>  as it is initialized
> > > >
> > > > earlier in the function with NULL and is not changed before
>  calling axis2_svc_client_send_receive_with_op_qname.
> > > >
> > > > I thing payload should not be null at this point . Please
 assist
>  me.
> > > >
> > > > Thank you,
> > > > Virgil.
> > > >
> > > >
> > > >
> > > >
>

  ------------------------------------------------------------------------
> > > >
> > > >
>
  ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> > > > For additional commands, e-mail: axis-c-user-help@ws.apache.org
> > > >
> > > >
> > > >
>

  ------------------------------------------------------------------------
> > > >
> > > > No virus found in this incoming message.
> > > > Checked by AVG Free Edition.
> > > > Version: 7.5.516 / Virus Database: 269.17.13/1213 - Release
 Date:
>  07.01.2008 09:14
> > >
> > >
>
  ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-c-user-help@ws.apache.org
> > >
> > >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org




Mime
View raw message