axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dimuthu Gamage" <dimut...@gmail.com>
Subject Re: codegeneration and service with no parameters
Date Fri, 14 Dec 2007 17:15:04 GMT
Hi Michael,
I tested your wsdl with the generated code from latest svn(The today's
snapshot would be the same) and axis2/c svn, and it worked.
I have attached the worked stub and skel here.

There were some improvements in the generated services.xml (adding
wsamapping parameter which identify the operation even if the request node
is empty as your case), but that should work even with axis2/c 1.1 in
theory. But IIRC there was a bug in action dispatching code sometime ago.
May be that was also in the axis2/c 1.1

So first please test the attached stub and skel which worked in my computer
with the latest axis2/c svn. If it is too not working in your computer,
better move to latest svn, or to axis2/c 1.2, most probably to be released
by next week

Thanks
Dimuthu



On Dec 14, 2007 9:47 PM, Michael Sutter <Michael.Sutter@ipe.fzk.de> wrote:

> Hello list,
>
> I have a problem with a generated service. My service has no input
> parameter and several output parameters. After implementing the service
> I always get the error message: Operation Not Found. So I searched
> through the generated code and found, that in the svc_skel of my service
> it is searched for the right function of my service but it is not called
> in the invoke function:
>
> if (op_name)
>          {
>                if ( axutil_strcmp(op_name, "getStatus") == 0 )
>                {
>
>                }
>             }
>
> If I understand right the error belongs to the code generation - am I
> right? If this is so I think it is a bug - what has to be done to fix
> it? For code generation I firstly used a snapshot of AXIS2 from some
> weeks ago. After detecting the error I also used a snapshot from today.
> There is the needed code in the svc_skel, but the error message is the
> same. Maybe I'm doing something wrong? Btw I found that the generated
> code from the actual version contains much more functions and the
> service.xml has different content - maybe it is not possible to host
> such a service in a AXIS2C 1.1 server?
>
> Attached is the WSDL and the code generated from the snapshot version
> some weeks ago.
>
> Regards Michael
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>

Mime
View raw message