axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Sutter <Michael.Sut...@ipe.fzk.de>
Subject apache module with SVN version
Date Mon, 17 Dec 2007 16:22:29 GMT
Hello list,

I checked out the SVN version and built it with apache2 daemon. After 
compiling I copied the libmod_axis2.so to apache module folder and 
changed the configuration of the module in /etc/apache2/httpd.conf.local 
to my current version:

LoadModule axis2_module /usr/lib/apache2-prefork/mod_axis2.so
Axis2RepoPath /home/auger/axis2c-1.2.0/
Axis2LogFile /tmp/axis2.log
Axis2LogLevel trace
# possible values: AXIS2_LOG_LEVEL_DEBUG AXIS2_LOG_LEVEL_TRACE
#Axis2LogLevel AXIS2_LOG_LEVEL_TRACE
<Location /axis2>
    SetHandler axis2_module
</Location>

After that I restarted the apache server and want to access it with a 
client. The problem is, that I directly get a Segmentation fault when 
accessing the service. In the log file /tmp/axis2.log is only one line:
[Mon Dec 17 13:10:25 2007] [info]  [Axis2] Axis2 worker created
But there must be much more as I used trace log level.

The client is working without problems with the axis_simple_server. I 
only changed the port for the apache server in it. Also I was using the 
apache module in version 1.1 without problems. Have I done something 
wrong or could it be a error in the module?

BTW im using apache 2.0.49 with gcc 3.3.3 but I also tried it with gcc 
4.1 - the same problem. I attached the log file of my client. It would 
be nice if anybody could help me.

Kind regards
Michael




Mime
View raw message