axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Pekarek" <filip.peka...@gmail.com>
Subject Re: trouble with calling extrenal ws
Date Thu, 15 Nov 2007 17:19:42 GMT
Hi Dinesh,
 I removed libaxis2.so and compiled my service without it and my problems
are solved. Somebody could repair the command in
http://ws.apache.org/axis2/c/docs/axis2c_manual.html#quick_start
<< 1.1.6 Compiling the Service >>

Thanks,
Filip


2007/11/14, Dinesh Premalal <xydinesh@gmail.com>:
>
> Hi Filip,
>
> "Filip Pekarek" <filip.pekarek@gmail.com> writes:
>
> > Hello,
> >  I can't call my ws. I am  getting  "[error]
> raw_xml_in_out_msg_recv.c(109)
> > Impl object for service... " .
> > Variables AXIS2C_HOME and LD_LIBRARY_PATH and permissions to directories
> are
> > set well. Where could be the problem?
>
> Seems like there is a problem in service implementation. Can you
> please attach the log file and services.xml? What is your service name
> and directory name that is inside services directory?
>
> >
> > Next thing  I would like to ask is how can I compile service using
> command:
> >     gcc -shared -olibhello.so -I$AXIS2C_HOME/include/axis2-1.0/
> -L$AXIS2C_HOME/
> > lib -laxis2 hello_svc.c
> > when there is no more library libaxis2.so in AXIS2C_HOME/lib directory
> (version
> > 1.1).
> I do not think, we need to link any library. Please look at
> Makefile.am the services implementation in samples/server they did not
> linked any library.
>
> thanks,
> Dinesh
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>

Mime
View raw message