axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Sutter <Michael.Sut...@ipe.fzk.de>
Subject Re: axis simple http server versus apache
Date Mon, 05 Nov 2007 14:41:37 GMT
Hello,

I found out what the problem is. I simply need a configuration file in 
my home directory. But this don't solved my problem.

The access to the libraries and files should be no problem - the apache 
daemon is running as the user running the axis simple server. So both 
have the rights to access all needed libraries. I think the problem is 
that apache is starting as root and then the processes are forked as 
another user - where maybe the environment of the user is not correctly 
set. Could this be? And does anybody has an idea how to solve it?

Kind regards Michael

Samisa Abeysinghe wrote:
> Michael Sutter wrote:
>> Hello Subra,
>>
>> thanks for your answer. But I had exported the LD_LIBRARY_PATH in the 
>> apache start script to the LD_LIBRARY_PATH I use when starting the 
>> axis simple server (done with echo $LD_LIBRARY_PATH).  The other 
>> difference I saw is  that the apache daemon runs as another user than 
>> the  axis simple server. So changed the user running the apache 
>> daemon to the user running the axis simple server.  So the library 
>> path should for both be the same and there should be no access 
>> violations for the libraries.
>>
>> But this don't work. In the error log I found the reason. My service 
>> access some corba classes and this produce the crash of the service. 
>> But I don't know why because the library path is the same in apache 
>> and axis server. Could it be that the apache generally could not 
>> access the corba classes and why?
> One reason that I can think of is permission problems. Some stuff that 
> the corba library does may require access rights beyond that of the 
> user under which apache is run.
>
> On a side note, for production systems, it is more appropriate to add 
> the lib path to /etc/ld.so.conf file and run ldconfig rather than to 
> set the LD_LIBRARY_PATH.
>
> Samisa...
>>
>> Kind regards
>> Michael
>>
>> Subra A Narayanan wrote:
>>> Hey Michael,
>>>
>>> I think the reason you are getting this error is because apache is 
>>> not able to locate and load one of you libraries. Try this:
>>>
>>> copy all ur shared libraries in to the /usr/lib (or /usr/lib64 ) 
>>> folder and try ur test with apache again. If that solves ur problem, 
>>> you may need to modify ur ld.so.conf file to add the location of ur 
>>> library files to tell apache where to look for the library files 
>>> that it needs.
>>>
>>> Subra
>>>
>>>
>>> On 10/31/07, *Michael Sutter * <Michael.Sutter@ipe.fzk.de 
>>> <mailto:Michael.Sutter@ipe.fzk.de>> wrote:
>>>
>>>     Hello list,
>>>
>>>     I have a problem with a service running in the apache webserver.
>>>     When I run the service with the axis simple server everything works
>>>     fine. But when I run it inside apache I always get:
>>>
>>>     raw_xml_in_out_msg_recv.c(109) Impl object for service 'DAQStatus'
>>>     not
>>>     set in message receiver. 100 :: Failed in creating DLL
>>>
>>>     When I understand the message right the service can't get the input
>>>     correct. Am I right? Does anybody know why this could occur and
>>>     why only
>>>     in apache?
>>>
>>>     The input is only a string - the output is a compley datatype
>>>     containing
>>>     6 boolean and 6 int variables.
>>>
>>>     Kind Regards
>>>     Michael
>>>
>>>     
>>> ---------------------------------------------------------------------
>>>     To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>>     <mailto:axis-c-user-unsubscribe@ws.apache.org>
>>>     For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>     <mailto:axis-c-user-help@ws.apache.org>
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message