axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sathya Raghunathan" <pappu.raghunat...@gmail.com>
Subject Re: Getting guththila exception
Date Thu, 20 Sep 2007 10:54:45 GMT
Hi

I installed libxml2.so, still i am getting the problem when i run the binary

ls -l /usr/lib/libxml2.so

lrwxrwxrwx    1 root     root           32 Sep 20 16:20 /usr/lib/libxml2.so
->
 /usr/local/lib/libxml2.so.2.6.23

"./axis2_http_server: relocation error: /home/sathya/axis2c/axis2c-
bin-1.0.0-linux/lib/libaxis2_parser.so.0: undefined symbol:
xmlReaderForFile"

If i say nm i can see that symbol

[root@CHNMCT63202 lib]# nm libxml2.so | grep xmlReaderForFile
000c16b8 T xmlReaderForFile

What else could be the problem

Thanks
Sathya

On 9/20/07, Sathya Raghunathan <pappu.raghunathan@gmail.com> wrote:
>
> Hi
>
> In my usr/lib, there are libxml2.so.2.5.10, /usr/lib/libxml2.so.2,
> /usr/lib/libxml2.a
> I am not sure which so, the binary would use. If this is old version, i
> will try to download and see
> Also, while doing a building the source I am getting an error called
> XML_PARSE_RECOVER undeclared error message.
>
> I check your website for solution and got that i need to download the file
> from apache site if this is not present in /usr/include/libxml2
>
> Let me know from where i can download the header file or the library?
>
> Thanks
> Sathya
>
> On 9/20/07, Samisa Abeysinghe <samisa@wso2.com> wrote:
> >
> > Sathya Raghunathan wrote:
> > > Should i rebuild the source again with --enable-libxml2=yes
> > > --enable-guththila=no??
> > >
> > > I am not using binary version because i got the error message
> > > "relocation error: /home/sathya/axis2c/axis2c-
> > > bin-1.0.0-linux/lib/libaxis2_parser.so.0: undefined symbol:
> > > xmlReaderForFile"
> > You get this error becuase you do not have libxml2 on your system or
> > because your libxml2 version is old.
> > I am using libxml2 version 2.6.23
> >
> > Samisa...
> >
> > >
> > > Let me know if i need to rebuild the axis source with the above
> > > configuration
> > >
> > > Thanks
> > > Sathya
> > >
> > > On 9/20/07, *Sathya Raghunathan* < pappu.raghunathan@gmail.com
> > > <mailto:pappu.raghunathan@gmail.com>> wrote:
> > >
> > >     I used both options as yes when i built the source.
> > >
> > >
> > >     On 9/20/07, *Dimuthu Gamage* < dimuthuc@gmail.com
> > >     <mailto:dimuthuc@gmail.com>> wrote:
> > >
> > >         Hi,
> > >
> > >         You can use libxml instead of xml as the xml parser. If you
> > >         are building from axis2 source configure it with the option
> > >         --enable-libxml2=yes --enable-guththila=no  (which is the
> > >         default configuration)
> > >         Or if you are using binary , use the libaxis2_libxml2.so (That
> > >         is put that in the LD_LIBRARY_PATH)
> > >
> > >         Thanks
> > >         DImuthu
> > >
> > >         On 9/20/07, *Sathya Raghunathan* < pappu.raghunathan@gmail.com
> > >         <mailto:pappu.raghunathan@gmail.com >> wrote:
> > >
> > >             Hi Dimuthu,
> > >
> > >             Thanks for helping me solve the segmentation fault. I
> > >             followed the calculator example. But now i am getting
> > >             another error called
> > >
> > >              "Throws guththila_exception guththila_xml_pull_parser.c
> > >             250."
> > >
> > >             Also it looks like its going in an infinite loop. When I
> > >             went to guththila_xml_pull_parser.c line 250, i checked
> > >             the if condition
> > >                else  if (((parser->_next) > (parser->last))
> > >                                       && guththila_read(environment,
> > >             parser))
> > >                 {
> > >                     if (eof)
> > >                         return -1;
> > >                     else
> > >                         guththila_exception(p_FILE, LINE,
> > >             GUTHTHILA_ERROR_UNEXPECTED_EOF
> > >             );
> > >                 }
> > >
> > >             Is there anything wrong with the input message again? I am
> > >             not able to proceed beyond this. I am attaching the client
> > >             code. I tried an input message with a "\n", and without a
> > >             "\n" at the end. Both gives a problem.
> > >
> > >             Please help me.
> > >
> > >             Thanks
> > >             Sathya
> > >
> > >
> > ---------------------------------------------------------------------
> > >             To unsubscribe, e-mail:
> > >             axis-c-user-unsubscribe@ws.apache.org
> > >             <mailto: axis-c-user-unsubscribe@ws.apache.org>
> > >             For additional commands, e-mail:
> > >             axis-c-user-help@ws.apache.org
> > >             <mailto: axis-c-user-help@ws.apache.org>
> > >
> > >
> > >
> > >
> >
> >
> > --
> > Samisa Abeysinghe : WSO2 WSF/PHP
> > "http://wso2.org/projects/wsf/php?WSO2&nbsp;Web&nbsp;Services&nbsp;Framework%2FPHP&nbsp;-&nbsp;Open&nbsp;source&nbsp;PHP&nbsp;extention&nbsp;for&nbsp;providing&nbsp;and&nbsp;consuming&nbsp;Web&nbsp;services&nbsp;in&nbsp;PHP
> >
> > <http://wso2.org/projects/wsf/php?WSO2%C2%A0Web%C2%A0Services%C2%A0Framework%2FPHP%C2%A0-%C2%A0Open%C2%A0source%C2%A0PHP%C2%A0extention%C2%A0for%C2%A0providing%C2%A0and%C2%A0consuming%C2%A0Web%C2%A0services%C2%A0in%C2%A0PHP>
> > "
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-c-user-help@ws.apache.org
> >
> >
>

Mime
View raw message