axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dinesh Premalal <xydin...@gmail.com>
Subject Re: dependencies for compiling svn version
Date Fri, 21 Sep 2007 13:37:41 GMT
Michael,
     Could you please confirm that you have automake 1.9 or higher?

thanks,
Dinesh

Michael Sutter <Michael.Sutter@ipe.fzk.de> writes:

> Hello Chintana and Sanjaya,
>
> when I run autoconf in the src folder or in the util folder I have the
> same output - nothing.
> I think this is not right.
>
> The error is printed in line 65 of the autogen.sh script - the first
> script called from the build.sh
>
> My question is if I'm right with all my variables  as I think?
>
> If I run the command in the especial line I get the following. But I
> don't know what it means. If I understand right the libtool library is
> used but something is undefined - what?
>
> src/core/addr/Makefile.am:1: Libtool library used but `LIBTOOL' is undefined
> src/core/addr/Makefile.am:1:
> src/core/addr/Makefile.am:1: The usual way to define `LIBTOOL' is to
> add `AC_PROG_LIBTOOL'
> src/core/addr/Makefile.am:1: to `configure.ac' and run `aclocal' and
> autoconf' again.
> src/core/clientapi/Makefile.am:1: Libtool library used but `LIBTOOL'
> is undefined
> src/core/clientapi/Makefile.am:1:
> src/core/clientapi/Makefile.am:1: The usual way to define `LIBTOOL' is
> to add `AC_PROG_LIBTOOL'
> src/core/clientapi/Makefile.am:1: to `configure.ac' and run `aclocal'
> and `autoconf' again.
> src/core/context/Makefile.am:1: Libtool library used but `LIBTOOL' is
> undefined
> src/core/context/Makefile.am:1:
> src/core/context/Makefile.am:1: The usual way to define `LIBTOOL' is
> to add `AC_PROG_LIBTOOL'
> src/core/context/Makefile.am:1: to `configure.ac' and run `aclocal'
> and `autoconf' again.
> src/core/deployment/Makefile.am:1: Libtool library used but `LIBTOOL'
> is undefined
> src/core/deployment/Makefile.am:1:
> src/core/deployment/Makefile.am:1: The usual way to define `LIBTOOL'
> is to add `AC_PROG_LIBTOOL'
> src/core/deployment/Makefile.am:1: to `configure.ac' and run `aclocal'
> and `autoconf' again.
> src/core/description/Makefile.am:1: Libtool library used but `LIBTOOL'
> is undefined
> src/core/description/Makefile.am:1:
> src/core/description/Makefile.am:1: The usual way to define `LIBTOOL'
> is to add `AC_PROG_LIBTOOL'
> src/core/description/Makefile.am:1: to `configure.ac' and run
> aclocal' and `autoconf' again.
> src/core/description/Makefile.am:17: variable
> libaxis2_engine_la_LDFLAGS' is defined but no program or
> src/core/description/Makefile.am:17: library has `libaxis2_engine_la'
> as canonic name (possible typo)
> src/core/engine/Makefile.am:1: Libtool library used but `LIBTOOL' is
> undefined
> src/core/engine/Makefile.am:1:
> src/core/engine/Makefile.am:1: The usual way to define `LIBTOOL' is to
> add `AC_PROG_LIBTOOL'
> src/core/engine/Makefile.am:1: to `configure.ac' and run `aclocal' and
> autoconf' again.
> src/core/phaseresolver/Makefile.am:1: Libtool library used but
> LIBTOOL' is undefined
> src/core/phaseresolver/Makefile.am:1:
> src/core/phaseresolver/Makefile.am:1: The usual way to define
> LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/core/phaseresolver/Makefile.am:1: to `configure.ac' and run
> aclocal' and `autoconf' again.
> src/core/receivers/Makefile.am:1: Libtool library used but `LIBTOOL'
> is undefined
> src/core/receivers/Makefile.am:1:
> src/core/receivers/Makefile.am:1: The usual way to define `LIBTOOL' is
> to add `AC_PROG_LIBTOOL'
> src/core/receivers/Makefile.am:1: to `configure.ac' and run `aclocal'
> and `autoconf' again.
> src/core/transport/http/common/Makefile.am:1: Libtool library used but
> LIBTOOL' is undefined
> src/core/transport/http/common/Makefile.am:1:
> src/core/transport/http/common/Makefile.am:1: The usual way to define
> LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/core/transport/http/common/Makefile.am:1: to `configure.ac' and
> run `aclocal' and `autoconf' again.
> src/core/transport/http/receiver/Makefile.am:1: Libtool library used
> but `LIBTOOL' is undefined
> src/core/transport/http/receiver/Makefile.am:1:
> src/core/transport/http/receiver/Makefile.am:1: The usual way to
> define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/core/transport/http/receiver/Makefile.am:1: to `configure.ac' and
> run `aclocal' and `autoconf' again.
> src/core/transport/http/sender/Makefile.am:2: Libtool library used but
> LIBTOOL' is undefined
> src/core/transport/http/sender/Makefile.am:2:
> src/core/transport/http/sender/Makefile.am:2: The usual way to define
> LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/core/transport/http/sender/Makefile.am:2: to `configure.ac' and
> run `aclocal' and `autoconf' again.
> src/core/transport/http/server/apache2/Makefile.am:1: Libtool library
> used but `LIBTOOL' is undefined
> src/core/transport/http/server/apache2/Makefile.am:1:
> src/core/transport/http/server/apache2/Makefile.am:1: The usual way to
> define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/core/transport/http/server/apache2/Makefile.am:1: to
> configure.ac' and run `aclocal' and `autoconf' again.
> src/core/transport/http/util/Makefile.am:2: Libtool library used but
> LIBTOOL' is undefined
> src/core/transport/http/util/Makefile.am:2:
> src/core/transport/http/util/Makefile.am:2: The usual way to define
> LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/core/transport/http/util/Makefile.am:2: to `configure.ac' and run
> aclocal' and `autoconf' again.
> src/core/transport/tcp/receiver/Makefile.am:1: Libtool library used
> but `LIBTOOL' is undefined
> src/core/transport/tcp/receiver/Makefile.am:1:
> src/core/transport/tcp/receiver/Makefile.am:1: The usual way to define
> LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/core/transport/tcp/receiver/Makefile.am:1: to `configure.ac' and
> run `aclocal' and `autoconf' again.
> src/core/transport/tcp/sender/Makefile.am:1: Libtool library used but
> LIBTOOL' is undefined
> src/core/transport/tcp/sender/Makefile.am:1:
> src/core/transport/tcp/sender/Makefile.am:1: The usual way to define
> LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/core/transport/tcp/sender/Makefile.am:1: to `configure.ac' and run
> aclocal' and `autoconf' again.
> src/core/util/Makefile.am:1: Libtool library used but `LIBTOOL' is undefined
> src/core/util/Makefile.am:1:
> src/core/util/Makefile.am:1: The usual way to define `LIBTOOL' is to
> add `AC_PROG_LIBTOOL'
> src/core/util/Makefile.am:1: to `configure.ac' and run `aclocal' and
> autoconf' again.
> src/modules/mod_addr/Makefile.am:2: Libtool library used but `LIBTOOL'
> is undefined
> src/modules/mod_addr/Makefile.am:2:
> src/modules/mod_addr/Makefile.am:2: The usual way to define `LIBTOOL'
> is to add `AC_PROG_LIBTOOL'
> src/modules/mod_addr/Makefile.am:2: to `configure.ac' and run
> aclocal' and `autoconf' again.
> src/modules/mod_log/Makefile.am:2: Libtool library used but `LIBTOOL'
> is undefined
> src/modules/mod_log/Makefile.am:2:
> src/modules/mod_log/Makefile.am:2: The usual way to define `LIBTOOL'
> is to add `AC_PROG_LIBTOOL'
> src/modules/mod_log/Makefile.am:2: to `configure.ac' and run `aclocal'
> and `autoconf' again.
>
> Michael
>
> Chintana Wilamuna wrote:
>> On 9/20/07, Michael Sutter <Michael.Sutter@ipe.fzk.de> wrote:
>>
>>   
>>> Running autogen.sh in Util
>>> Running libtoolize...done.
>>> Running aclocal...done.
>>> Running autoheader...done.
>>> Running autoconf...failed.
>>>     
>>
>> Mark,
>>
>> Looks like autoconf is failing in the Util folder.  Can you cd into
>> util and type autoconf?  That should give an idea about what exactly
>> is going on with autoconf.
>>
>> Bye,
>>
>>     -Chintana
>>
>>   
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>

-- 
Dinesh Premalal
http://xydinesh.wordpress.com/
GPG ID : A255955C
GPG Key Finger Print : C481 E5D4 C27E DC34 9257  0229 4F44 266E A255 955C

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message