axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Callner, David A." <dcall...@mitre.org>
Subject RE: Compiling and Linking WSDL2C
Date Mon, 17 Sep 2007 14:09:23 GMT
 
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `apr_pool_create_ex'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_hook_handler'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_check_cmd_context'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_getword_conf'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_hook_child_init'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_setup_client_block'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `apr_pstrdup'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_log_error'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `apr_table_get'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `apr_palloc'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_should_client_block'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_rwrite'
/home/dcallner/axis2c-bin-1.0.0-linux/lib/libmod_axis2.so: undefined
reference to `ap_get_client_block'

-----Original Message-----
From: Samisa Abeysinghe [mailto:samisa@wso2.com] 
Sent: Sunday, September 16, 2007 9:27 PM
To: Apache AXIS C User List
Subject: Re: Compiling and Linking WSDL2C

Callner, David A. wrote:
> I'm using Axis2-1.2/Java and Axis2c-1.0.0.  I've tried the following 
> combinations but all have failed.  Axis2-1.3/Java and Axis2c-1.0.0, 
> Axis2-1.2 and Axis2c-0.96, Axis2-1.1.1 and Axis2c0.96. 
>  
> I am able to generate the code using any of the Axis2/Java's above, 
> but none of the generated code compiles.  I've created Makefiles and 
> link in all the libraries from $AXIS2C_HOME/lib . 
>  
> Using Axis2-1.2/WSDL2C
>  
> I've noticed the following compiler errors.  first_node = param0;  
> first_node is never defined in the code.  For the generated requests 
> and responses inside the _stub_Service code the types that are
defined 
> on the parameters do not exists.
>  
>  
> Using Axis2-1.3/WSDL2C and Axis2-SNAPSHOT/WSDL2C
>  
> I can compile the code fine but I get tons of link errors.  I've 
> linked in all the libraries out of the $AXIS2C_HOME/lib directory so 
> what could be the problem? 
Please send the linker output, so that we could figure out what the 
problem is.

Samisa...

-- 
Samisa Abeysinghe : WSO2 WSF/C
"http://wso2.org/projects/wsf/c?WSO2&nbsp;Web&nbsp;Services&nbsp;Framew
ork/C&nbsp;-&nbsp;Open&nbsp;source&nbsp;C&nbsp;library&nbsp;for&nbsp;pr
oviding&nbsp;and&nbsp;consuming&nbsp;Web&nbsp;services"


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message