axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Nüßler <mark.nuess...@9elements.com>
Subject Re: AW: echo.exe client has "infer transport" error
Date Wed, 19 Sep 2007 09:51:38 GMT
hello josef,

another tool, that can help you with this kind
of problems maybe is 'filemon' from sysinternals.

i saw, that you are using vs2005,
maybe it is helpful to you to build the axis2c from
scratch using 'DEBUG=1' in build\win32\configure.in

when i run a service in vs2005 i start the
axis2_http-server from the debug-options

command : axis2_http_server.exe
args : -p 8081
workingdir : $(AXIS2_C)\bin

if you are using adb to generate, i
have written a little tool, that
creates the vs-project-files [2003/2005]

mfg derMark


Stadelmann Josef schrieb:
> Hi Dinesh
> 
> thank you very much. Debugging was helpfule/timeconsuming/learningful.
> I was down to step through the processing of phases and transports etc.
> Then I detected that axis2_http_sender.dll was unable to load, and that
> was caused due to the absence of libcurl.dll e all in ./lib
> 
> Missing DLL are flagged YELLOW and question marked in Dependency Walker
> 
> The problem is that LoadLib( ... ) does either return a handle to the
> dll just loaded or zero in case of error but does not tell you why a 
> dll does not load. And the rest is how axis e all interpret this error.
> 
> Now my echo.exe is running
> 
> The tool who helps most in detecting the absence of a dll is the
> 
> 	Dependency Walker for Win32 (X86)
> 	Version 2.0 (or greater)
> 	Developed by Steve P. Miller
> 	Copyright by MS Corp. 
> 
> It gives a nice ide about depedencies among dll's
> 
> The I had to restart the server and the client went OK
> 
> Thank you very much again for your help.
> 
> Josef
> 
> 
> -----Ursprüngliche Nachricht-----
> Von: Dinesh Premalal [mailto:premalal@gmail.com]Im Auftrag von Dinesh
> Premalal
> Gesendet: Dienstag, 18. September 2007 17:20
> An: axis-c-user@ws.apache.org
> Betreff: Re: echo.exe client has "infer transport" error
> 
> 
> Hi Josef,
>       Please find my comments inline.
> "Stadelmann Josef" <josef.stadelmann@axa-winterthur.ch> writes:
>> Starting the echo.exe client fails!
>>
>> The echo.log shows me
>>
>> [Tue Sep 18 11:34:34 2007] [error] c:\dsa5\webservices\axis2\trunk\c\src\core\clientapi\op_client.c(863)
[axis2c] Cannot infer transport
>>
>> (log attached)
>>
>> I do not get any trabnsport_out_desc !but sorry, I dont know where and how to define
a transport out description such a way that
> I think, client is unable to find repo location to pickup
> axis2.xml. Most of the time can't infer transport error message
> appears when client unable to pickup axis2.xml.  Because when loading
> axis2 engine, it uses axis2.xml to set transport_out_desc.
> 
> 1. Please check whether you set $AXIS2C_HOME or client can pickup
> axis2.xml from "../.." location.
> 
> <snippet location="axis2c/samples/client/echo/echo.c">
>    client_home = AXIS2_GETENV("AXIS2C_HOME");
>    if (!client_home || !strcmp (client_home, ""))
>        client_home = "../..";
> </snippet>
> 
> thanks,
> Dinesh

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message