axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sahan Gamage" <sah...@gmail.com>
Subject Re: Service compilation problem
Date Mon, 06 Aug 2007 03:25:50 GMT
Hi Subra,

You're trying to do a REST style invocation. Are you running
axis2_http_server on port 80 ? If you're trying the default options
(by just typing ./axis2_http_server) the default port is 9090. So you
have to try the URL:
http://localhost:9090/axis2/services/math/add?param1=5&param2=9

-sahan

On 8/6/07, Subra A Narayanan <aswathsn@gmail.com> wrote:
> I am still waiting to hear from you guys as to what you think is causing the
> problem. Any help/pointers is greatly appreciated.
>
>
> ---------- Forwarded message ----------
> From: Subra A Narayanan <aswathsn@gmail.com>
> Date: Aug 3, 2007 9:39 AM
> Subject: Re: Service compilation problem
> To: Apache AXIS C User List < axis-c-user@ws.apache.org>
>
> Hello,
>
> Thanks for all your responses.
>
> Sahan, I am using the same services.xml file that came with the math sample.
>
> Here is what I see
>
> 1. I type in
> http://localhost/axis2/services/math/add?param1=5&param2=9
>
>
> 2. I get a "Page cannot be displayed" error in my web browser
>
> 3. In the log file I see this
>
> [Fri Aug  3 09:10:55 2007] [debug] apache2_worker.c(143)
> Client HTTP version HTTP/1.1
> [Fri Aug  3 09:10:55 2007] [debug] req_uri_disp.c(103) Checking for service
> using target endpoint address :
> /axis2/services/math/add?param1=5&param2=9
> [Fri Aug  3 09:10:55 2007] [debug] req_uri_disp.c(124) Service found using
> target endpoint address
> [Fri Aug  3 09:10:55 2007] [debug] req_uri_disp.c(169) Checking for
> operation using                              target
> endpoint uri fragment : add
> [Fri Aug  3 09:10:55 2007] [debug] req_uri_disp.c(178) Operation found using
> target endpoint uri fragment
> [Fri Aug  3 09:10:55 2007] [debug] engine.c(571) Invoking phase Transport
> [Fri Aug  3 09:10:55 2007] [debug] phase.c(195) Invoke the handler
> request_uri_based_dispatcher within the phase Transport
> [Fri Aug  3 09:10:55 2007] [debug] engine.c(571) Invoking phase PreDispatch
> [Fri Aug  3 09:10:55 2007] [debug] phase.c(195) Invoke the handler
> AddressingInHandler within the phase PreDispatch
> [Fri Aug  3 09:10:55 2007] [info]  Starting addressing in handler .........
> [Fri Aug  3 09:10:55 2007] [info]  addr_in_handler.c
> [Fri Aug  3 09:10:55 2007] [debug] phase.c(195) Invoke the handler
> LoggingInHandler within the phase PreDispatch
> [Fri Aug  3 09:10:55 2007] [info]  Starting logging in handler .........
> [Fri Aug  3 09:10:55 2007] [info]  Input message: <soapenv:Envelope
> xmlns:soapenv="
> http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header></soapenv:Header><soapenv:Body><add><param1>5</param1><param2>9</param2></add></soapenv:Body></soapenv:Envelope
> >
> [Fri Aug  3 09:10:55 2007] [debug] engine.c(571) Invoking phase Dispatch
> [Fri Aug  3 09:10:55 2007] [debug] phase.c(195) Invoke the handler
> soap_message_body_based_dispatcher within the phase
> Dispatch
> [Fri Aug  3 09:10:55 2007] [debug] phase.c(195) Invoke the handler
> addressing_based_dispatcher within the phase Dispatch
> [Fri Aug  3 09:10:55 2007] [debug] phase.c(195) Invoke the handler
> soap_action_based_dispatcher within the phase Dispatch
> [Fri Aug  3 09:10:55 2007] [debug] engine.c(571) Invoking phase PostDispatch
> [Fri Aug  3 09:10:55 2007] [debug] phase.c(195) Invoke the handler
> dispatch_post_conditions_evaluator within the phase
> PostDispatch
> [Fri Aug  3 09:10:55 2007] [debug] phase.c (195) Invoke the handler
> context_handler within the phase PostDispatch
>
>
> As you can see from the above log file, the server just hangs after "Invoke
> the handler context_handler within the phase PostDispatch" step.
>
> I found a similar post in the archive, probably this will give you guys more
> idea as to what is happening.
>
> http://marc.info/?l=axis-c-user&m=118125285316252&w=2
>
> Thanks everyone for ur help. Its greatly appreciated.
>
> Subra
>
>
>
>
>
>
>
> On 8/3/07, Dr. Florian Steinborn <florian.steinborn@drb.insel.de > wrote:
> > Hi,
> >
> > > I see a libmath.so file being generated. But my service doesn't work. I
> >
> > what does it mean, "doesn't work"? Does not work at all, you cannot see an
> > invocation, the service crashes? What about logging?
> >
> > Greeting,
> > Flori
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> axis-c-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-c-user-help@ws.apache.org
> >
> >
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message