axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjaya Ratnaweera <sanj...@wso2.com>
Subject Re: [Axis2/C]: SOAP request with line breaks fails
Date Wed, 08 Aug 2007 05:03:30 GMT
Subra A Narayanan wrote:
> Hey Manjula,
>
> I checked out the latest source code from svn and built it.
>
> But when I try to build the samples, I get an error. Since there is no 
> configue.sh file in the samples directory, I had to run the build.sh 
> script file. It dies half way through. This is the error I get
>
> ...................
> ...................
> checking for string.h... (cached) yes
> checking for an ANSI C-conforming const... yes
> ./configure: line 20467: syntax error near unexpected token `LIBXML2,'
> ./configure: line 20467: `PKG_CHECK_MODULES(LIBXML2, libxml-2.0)'
> make: *** No targets specified and no makefile found.  Stop.
> make: *** No rule to make target `install'.  Stop.
>

Hi Subra,

     What's the operating system you're working on? You have to install 
pkg-config to run PKG_CHECK_MODULES. Try installing it?

Thanks

    ~sanjaya


>
> I would like to mention that when I tried building axis2/c from 
> source, it complained about pkg-config version should be atleast 0.20 
> and I had 0.19. So I downloaded, built and installed pkg-config 0.22 
> version. It was installed in the /usr/local/bin directory as compared 
> to version 0.19 which was installed in /usr/bin directory.
>
> Thanks for the help!
>
> Subra
>
>
> On 8/7/07, *Manjula Peiris* <manjula@wso2.com 
> <mailto:manjula@wso2.com>> wrote:
>
>     Hi subra,
>
>     This is a bug in Axis2/C 1.0. But it has been fixed after 1.0 and
>     in the
>     current svn trunk it is working.
>
>     -Manjula.
>
>     On Mon, 2007-08-06 at 22:57 -0400, Subra A Narayanan wrote:
>     > Hey Samisa,
>     >
>     > I am using Axis2/C 1.0, source distribution on Linux. I compiled the
>     > source with the apache http module.
>     >
>     > Thanks for your follow-up abt my earlier issue. I will respond
>     to that
>     > email separately so that someone following that thread will also
>     > benefit.
>     >
>     > Thanks again for ur quick response!
>     >
>     > Subra
>     >
>     > On 8/6/07, Samisa Abeysinghe <samisa@wso2.com
>     <mailto:samisa@wso2.com>> wrote:
>     >         What version of Axis2/C you are using? We had a problem
>     like
>     >         this, but
>     >         if I remember right we have fixed it.
>     >
>     >         BTW, have you been able to solve the service compilation
>     >         problem that
>     >         you discussed in the other thread?
>     >
>     >         Samisa...
>     >
>     >
>     >         Subra A Narayanan wrote:
>     >         > Hello everyone,
>     >         >
>     >         > I found an interesting issue today and was wondering if
>     >         someone else
>     >         > has seen tha same issue before. I am using Axis2/C on
>     Linux.
>     >         >
>     >         > I have a web service running. When the client tries
>     calling
>     >         the web
>     >         > service using SOAP, the web service works if there are no
>     >         line breaks
>     >         > in the SOAP request. If there are any line breaks, the
>     >         server just
>     >         > crashes. So for eg
>     >         >
>     >         > ==> This works (SOAP msg with no line breaks)
>     >         >
>     >         > <soapenv:Envelope xmlns:soapenv="
>     >         >
>     >        
>     http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header></soapenv:Header><soapenv:Body><RemoveFile><Owner>jordan</Owner><FileName>
>     sircharles.gif</FileName><FileID>1234</FileID></RemoveFile></soapenv:Body></soapenv:Envelope>
>
>     >         >
>     >         >
>     >         > ==> while this fails (formatted SOAP msg with line breaks)
>     >         >
>     >         > <env:Envelope xmlns:xsi="
>     >         http://www.w3.org/2001/XMLSchema-instance"
>     >         > xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
>     >         xmlns:xsd="
>     >         > http://www.w3.org/2001/XMLSchema">
>     >         >   <env:Header></env:Header>
>     >         >   <env:Body>
>     >         >     <n1:RemoveFile xmlns:n1="
>     http://www.xyz.com/2007/07/ ">
>     >         >       <n1:Owner>harry</n1:Owner>
>     >         >       <n1:FileName>del1.jpg </n1:FileName>
>     >         >       <n1:FileID>checksum</n1:FileID>
>     >         >     </n1:RemoveFile>
>     >         >   </env:Body>
>     >         > </env:Envelope>
>     >         >
>     >         > ==>This is what I see in the axis2.log file
>     >         >
>     >         > [Mon Aug  6 13:59:22 2007] [debug] engine.c(571) Invoking
>     >         phase Dispatch
>     >         > [Mon Aug  6 13:59:22 2007] [debug] phase.c(195) Invoke the
>     >         handler
>     >         > soap_message_body_based_dispatcher within the phase
>     >         Dispatch
>     >         > [Mon Aug  6 13:59:22 2007] [debug] soap_body_disp.c(217)
>     >         Checking for
>     >         > operation using SOAP message body's first child's local
>     >         name : RemoveFile
>     >         > [Mon Aug  6 13:59:22 2007] [debug] soap_body_disp.c(226)
>     >         Operation
>     >         > found using SOAP message body's first child's local name
>     >         > [Mon Aug  6 13:59:22 2007] [debug] phase.c(195) Invoke the
>     >         handler
>     >         > addressing_based_dispatcher within the phase Dispatch
>     >         > [Mon Aug  6 13:59:22 2007] [debug] phase.c(195) Invoke the
>     >         handler
>     >         > soap_action_based_dispatcher within the phase Dispatch
>     >         > [Mon Aug  6 13:59:22 2007] [debug] engine.c(571) Invoking
>     >         phase
>     >         > PostDispatch
>     >         > [Mon Aug  6 13:59:22 2007] [debug] phase.c(195) Invoke the
>     >         handler
>     >         > dispatch_post_conditions_evaluator within the phase
>     >         PostDispatch
>     >         > [Mon Aug  6 13:59:22 2007] [debug] phase.c(195) Invoke the
>     >         handler
>     >         > context_handler within the phase PostDispatch
>     >         > [Mon Aug  6 13:59:22 2007] [debug] class_loader.c(135)
>     >         Object loaded
>     >         > successfully
>     >         > [Mon Aug  6 13:59:23 2007] [info]  Starting log with log
>     >         level 5
>     >         >
>     >         >
>     >         > ==> so basically the server restarts after the
>     >         "class_loader.c(135)
>     >         > Object loaded successfully" step.
>     >         >
>     >         > The client code was written in Ruby. I dont know how I can
>     >         tell Ruby
>     >         > not to insert line breaks. But have you guys seen this
>     issue
>     >         before?
>     >         > Do you know a solution to this problem?
>     >         >
>     >         > TIA
>     >         > Subra
>     >
>     >
>     >         --
>     >         Samisa Abeysinghe : http://www.wso2.org/ (WSO2 Oxygen Tank -
>     >         Web Services Developers' Portal)
>     >
>     >
>     >        
>     ---------------------------------------------------------------------
>     >         To unsubscribe, e-mail:
>     axis-c-user-unsubscribe@ws.apache.org
>     <mailto:axis-c-user-unsubscribe@ws.apache.org>
>     >         For additional commands, e-mail:
>     >         axis-c-user-help@ws.apache.org
>     <mailto:axis-c-user-help@ws.apache.org>
>     >
>     >
>
>
>     ---------------------------------------------------------------------
>     To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>     <mailto:axis-c-user-unsubscribe@ws.apache.org>
>     For additional commands, e-mail: axis-c-user-help@ws.apache.org
>     <mailto:axis-c-user-help@ws.apache.org>
>
>


Mime
View raw message