axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manoj Rao" <rma...@aylus.com>
Subject RE: Services.xml
Date Mon, 23 Jul 2007 08:32:21 GMT
Ok Maybe I was not clear in my previous emails, sorry. I am using 1.0's 
axis2.xml and when I send a request from the client my application dies 
after invoking the handler context_handler in PostDispatch phase. 
Backtrace from core shows the following.

========================================================================
(gdb) bt
#0  axis2_msg_recv_make_new_svc_obj (msg_recv=0x8194290, env=0x81fbe28, 
msg_ctx=0x81fc8f0) at msg_recv.c:157
#1  0xb7a61b35 in axis2_msg_recv_get_impl_obj (msg_recv=0x8194290, 
env=0x81fbe28, msg_ctx=0x81fc8f0) at msg_recv.c:184
#2  0xb7a61fc2 in 
axis2_raw_xml_in_out_msg_recv_invoke_business_logic_sync 
(msg_recv=0x8194290, env=0x81fbe28,
    msg_ctx=0x81fc8f0, new_msg_ctx=0x8204e50) at 
raw_xml_in_out_msg_recv.c:93
#3  0xb7a61694 in axis2_msg_recv_invoke_business_logic 
(msg_recv=0x8194290, env=0x81fbe28, in_msg_ctx=0x81fc8f0,
    out_msg_ctx=0x8204e50) at msg_recv.c:372
#4  0xb7a61c4d in axis2_msg_recv_receive_impl (msg_recv=0x8194290, 
env=0x81fbe28, msg_ctx=0x81fc8f0,
    callback_recv_param=0x0) at msg_recv.c:304
#5  0xb7a61714 in axis2_msg_recv_receive (msg_recv=0x8194290, 
env=0x81fbe28, msg_ctx=0x81fc8f0, callback_recv_param=0x0)
    at msg_recv.c:407
#6  0xb7a59aac in axis2_engine_receive (engine=0x82045b0, env=0x81fbe28, 
msg_ctx=0x81fc8f0) at engine.c:288
#7  0xb7a7e144 in axis2_http_transport_utils_process_http_post_request 
(env=0x81fbe28, msg_ctx=0x81fc8f0,
    in_stream=0x81fbe58, out_stream=0x81fbff0, content_type=0x81fbef8 
"text/xml; charset=utf-8", content_length=632,
    soap_action_header=0x81fcc30, request_uri=0x81fca78 
"http://127.0.0.1:9090/axis2/services/SpsMvnoprofile")
    at http_transport_utils.c:485
#8  0xb76ad307 in axis2_http_worker_process_request 
(http_worker=0x81fa9d8, env=0x81fbe28, svr_conn=0x81fbe48,
    simple_request=0x81fbee0) at http_worker.c:299
#9  0xb7a8db72 in axis2_svr_thread_worker_func (thd=0x81fbda0, 
data=0x81faa10) at http_svr_thread.c:256
#10 0xb7aad9fd in dummy_worker () from /opt/aylus/lib/libaxutil.so.0
#11 0xb7f510bd in start_thread () from /lib/tls/libpthread.so.0
#12 0xb793b9ee in clone () from /lib/tls/libc.so.6
========================================================================

I am not quite sure what the problem is, AXIS2_SVC_SKELETON_INIT fails 
as impl_class = 0x00

-----Original Message-----
From: Dinesh Premalal [mailto:xydinesh@gmail.com] 
Sent: Monday, July 23, 2007 1:43 PM
To: axis-c-user@ws.apache.org
Subject: Re: Services.xml

Hi Manoj,
"Manoj Rao" <rmanoj@aylus.com> writes:

> Hi Dinesh,
> Thanks for the reply. I was using axis2c 0.90 till recently and now 
> migrated to 1.0 the same services.xml doesn't work here is there 
> anything I need to change in axis2.xml before using it? Sample of my 
> working services.xml is the simple math sample.
It is the same services.xml still in math sample. AFAIK there is no
special changes required in axis2.xml. What does your axis2.log says ?

thanks,
Dinesh

-- 
Dinesh Premalal
http://xydinesh.wordpress.com/
GPG ID : A255955C
GPG Key Finger Print : C481 E5D4 C27E DC34 9257  0229 4F44 266E A255 
955C

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message