axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raghavendra SM" <rag...@aylus.com>
Subject RE: Services.xml
Date Fri, 27 Jul 2007 03:14:58 GMT
Oh Sorry, "acc_invoke" was a typo error, and it actually is "my_invoke". 
Even then I face the same problem. Please take another look & let us 
know if you need more information of any sort.

Regards,
~raghav
 

-----Original Message-----
From: Samisa Abeysinghe [mailto:samisa@wso2.com] 
Sent: Friday, July 27, 2007 6:53 AM
To: Apache AXIS C User List
Subject: Re: Services.xml

Raghavendra SM wrote:
> Hi Samisa,
>
> Please find the server code below, which is causing the problems as 
> described by Manoj Rao. Please let me know if need more information 
than 
> this.
>
> These are the skeleton functions of the server.
>   
I think I found the problem. In your my_svc_skeleton_ops_var variable, 
you have provided my_invoke as the invoke function. However, in your 
source, there is no such function, rather a function named acc_invoke. I 

think you have to rename acc_invoke to my_invoke and try.

Also in the my_init function, you do not need to initialize 
svc_skeleton->func_array. You can safely comment whole of my_init 
function, leaving only the return AXIS2_SUCCESS; line in there.

HTH.

Thanks,
Samisa...

-- 
Samisa Abeysinghe : http://www.wso2.org/ (WSO2 Oxygen Tank - Web 
Services Developers' Portal)


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message