axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaushalye Kapuruge <kausha...@wso2.com>
Subject Re: rampart/c not working with stubs generated using wsdl2c
Date Mon, 23 Jul 2007 12:06:05 GMT
Hi Sharada,
Could you pls send us the generated client code?
Then we can see what's wrong with it. Reading the log it's clear that 
Rampart is not in the outgoing path for the generated client. So there 
is no way of adding security headers.
Also we believe that you have specified AXIS2C_HOME correctly.
Cheers,
Kaushalye

sharada.deshpande@pfpc.com wrote:
> Hi Manjula,
>
> Here is the axis2.xml I am using.(See attached file: axis2.xml)
>
>            I am using the same axis2.xml file in both manual and through
> stub. After seeing your reply I thought may be my stub program is not
> invoking the correct axis2.xml and added the following line in my stub.
>       axis2_svc_client_engage_module(svc_client, env,"rampart");
>
> But now I see the error that rampart is already engaged. That means it is
> reading from both axis2.xml and my stub, right?
>
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_holder.c(129) Add handler
> RampartOutHandler to phase MessageOut
> [Mon Jul 23 07:24:49 2007] [info]  [rampart][mod_rampart] mod_rampart
> initialized
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(117) Service name is :
> __ANONYMOUS_SERVICE__
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_holder.c(129) Add handler
> RampartOutHandler to phase MessageOut
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_holder.c(129) Add handler
> RampartOutHandler to phase MessageOut
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_holder.c(129) Add handler
> RampartOutHandler to phase MessageOut
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(231) module name is:rampart
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(117) Service name is :
> __ANONYMOUS_SERVICE__
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(1298) Module rampart already
> engaged.
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(1298) Module rampart already
> engaged.
> [Mon Jul 23 07:24:49 2007] [debug]
> ..\..\src\core\phaseresolver\phase_resolver.c(1502) Handler inclusion
> failed for MessageOut phase
> [Mon Jul 23 07:24:51 2007] [debug]
> ..\..\src\core\transport\http\sender\http_transport_sender.c(566) OP name
> axutil_qname_get_localpart = http://www.w3.org/2004/08/wsdl/out-in
> [Mon Jul 23 07:24:51 2007] [debug] ..\..\axiom\src\soap\soap_builder.c(737)
> Identified soap version is soap11
> [Mon Jul 23 07:24:51 2007] [debug] ..\..\src\core\engine\engine.c(179)
> Axis2 engine send successful
>
> Thank you
> Sharada
>
>
>
>                                                                            
>              Manjula Peiris                                                
>              <manjula@wso2.com                                             
>              >                                                          To 
>                                        Apache AXIS C User List             
>              07/23/2007 05:01          <axis-c-user@ws.apache.org>         
>              AM                                                         cc 
>                                                                            
>                                                                    Subject 
>              Please respond to         Re: rampart/c not working with      
>               "Apache AXIS C           stubs generated using wsdl2c        
>                 User List"                                                 
>              <axis-c-user@ws.a                                             
>                 pache.org>                                                 
>                                                                            
>                                                                            
>                                                                            
>
>
>
>
> Hi Sharda,
>
> To add wsse:headers you have to engage rampart. Seems to me rampart
> module is not engaged in the generated code. How did you engage rampart
> in the working code where you have created the soap body manually?
>
> You have two options to engage rampart.
>
> 1. Adding a module ref entry in axis2.xml.
>
> <module ref="rampart"/>
>
> 2. Engaging programmatically from your client code.
>
> axis2_svc_client_engage_module(svc_client, env,"rampart");
>
> If you can, please send the axis2.xml you are using.
>
> Thanks
> -Manjula.
>
> On Sun, 2007-07-22 at 09:47 -0400, sharada.deshpande@pfpc.com wrote:
>   
>> Hi,
>>
>>      My webservice client program with rampart/c configured to add wsse
>> headers works when I create the soap body manually and call the method
>> axiom_node_t* ret_node = axis2_svc_client_send_receive(svc_client, env,
>> payload);
>>
>> (See attached file: BL_client.log)
>>
>>
>> But with the same rampart/c and axis2.xml configuration, if I try to use
>> the stubs generated by wsdl2c tool, I do not see the wsse:headers added
>>     
> to
>   
>> the request. Any ideas why?
>>
>> (See attached file: BL_client_stub.log)
>>
>> I have both working and not-working logs attached.
>>
>>
>> Thank a lot
>> Sharada
>>
>> The contents of this email are the property of the sender. If it was not
>>     
> addressed to you, you have no legal right to read it. If you think you
> received it in error, please notify the sender. Do not forward or copy
> without permission of the sender.
>   
>> --------------------------------------------------------------------- To
>>     
> unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org For additional
> commands, e-mail: axis-c-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>
>
> The contents of this email are the property of the sender. If it was not addressed to
you, you have no legal right to read it. If you think you received it in error, please notify
the sender. Do not forward or copy without permission of the sender.
> ------------------------------------------------------------------------
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org


-- 
http://kaushalye.blogspot.com/
http://wso2.org/


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message